Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS Subsistence ntsc-u strange glitches/random fps drops
#1
Dear PCSX2 Forums,

Firstly High again to all the mods! It's been a while since I had the pleasure of speaking to Bositman and others. Firstly, Thanks again for all the pcsx2 team AMAZING work, you guys all rock and your AWESOME! I have a lot of respect for you dedication and impressive programming skills and accomplishments! Secondly, I apologize for being another please help me case, I'm sure you get loads of them ^_^0 I did search the forums via google, but could not find an applicable solution to my problems.

I'm using the latest official SVN build (when I wrote this) 1.1.0.r5620 Below are my pc specs:

Corsair 650D case
Rampage IV extreme Motherboard
Intel I7 3820 (Quad) @ 4.3ghz
Corsair H100 Hydro CPU Cooler
GTX 680 4GB Evga Classified/Palit Jetstream 4GB SLI
(I use the Evga only for pcsx2)
Kingston Hyper X Genesis 16GB 2133mhz ram
ASUS Xonar Essence STX soundcard
240GB KINGSTON HYPERX 3K SSD, SATA 6 Gb/s
1TB WD CAVIAR BLACK
CORSAIR 1200W PRO SERIES™ PLATINUM AX1200i psu

SO! Basically I'm trying to play Metal Gear solid subsistence NTSC-U! I own the super version with persistence and existence (which I'm proud of!)
The game runs pretty much perfect at 2560x1440 res 60fps for me most of the time, including the opening fmv - MOSTLY. However it oddly dips suddenly to 40, even 30 for a few seconds at a time and then returns to 60fps (during fmv). Also, there are weird multi colored squares that suddenly flash in front of the screen for a moment then vanish during the opening fmv. I've only just started the game (this play through, on pcsx2 for the first time) and I really want to try and keep the fps a consistent 60, and avoid weird graphical errors. Also, during the opening sequence it sometimes hangs/freezes on the an exterior shot of the troop carrier plane Snake's on (i'm not sure what did/didn't cause this - maybe speedhacks? But they where recommended elsewhere on the forums by a mod with a chinese lady as an avatar - I forget the screen name sorry)

My pcsx2 setting are as follows:

gsdx: directX 11 custom res 2560x1440 tex filt allow 8bit HW hacks - alpha, half pixel offset
Audioi: Catmull, waveout, async
emu set: recompilers, microvu chop zero/normal no vsync speedhacks on, no cycle steel or cycle rate, enable fast cdvd off, gamefixes auto. I also found a patch for subsistence that "enables roundmode" It was supposed to fix problems so I tried activating it, but i'm not sure what the actual difference is?

Thank you for any suggestions, help you can provide. All the best -

Myles Thomas
Reply

Sponsored links

#2
Im not sure about the funny squares issue, this may be helped by changing the Clamping modes to full or Full + Extra (preserve sign or smth), other than that i don't know.

As for the speed drops, have you tried using the MTVU speedhack? It helps greatly in this game and may resolve your slowness issues. Other possible causes for speed drops could be the resolution you are running the game in, you could try dropping it down, also SLi has been known to cause issues, so you could try turning that off. But i would try the MTVU speedhack first and then we can look in to other possibilities Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(04-22-2013, 04:29 PM)refraction Wrote: Im not sure about the funny squares issue, this may be helped by changing the Clamping modes to full or Full + Extra (preserve sign or smth), other than that i don't know.

As for the speed drops, have you tried using the MTVU speedhack? It helps greatly in this game and may resolve your slowness issues. Other possible causes for speed drops could be the resolution you are running the game in, you could try dropping it down, also SLi has been known to cause issues, so you could try turning that off. But i would try the MTVU speedhack first and then we can look in to other possibilities Smile

Thank you for your reply Refraction sir. I am using the MTVU speed hack, and the other speed hacks but not cdvd speedup or the cycle steal/rate's. I will use full and full + Extra from now on, I was only refraining from using them because I thought it might be adding to the speed issue. I had already disabled SLI, as I have found it to be less effective. Would you happen to know of the "round mode" pnach for subsistence I speak of, and if it's helping or the opposite? I'll provide a link if you don't know what I mean. I would like to think there is a way I could use 2560x1440 throughout the game without big speed drops, but so far the only one's I've had where in the opening movie, for moments at a time, maybe I should play further till the next fmv, and see if the problem reoccurs.

Hi! UPDATE!

I found that the nearest FULL/ extra+ caused the game to freeze during the opening fmv. The "squares" have disappeared I think due to the hwhacks I was using, and the MTVU hack plus mild EE cycle rate increase boosts fps, and makes things smoother.I also found that the direct sound option on spu2 made everything sound better (after some research into spu2 vs waveout). So on the whole it's working better, but, although only minor, those brief slowdowns where a little annoying. But with async, if I weren't watching the fps counter intently I don't think it would bother me nearly as much lol. Still, it'd be nice to find a way to 'iron out the creases.'
I heard there is a widescreen hack for subsistence, would you know how I might find this? Finally, I will do as I said and continue to the next fmv('s) and let you know if there are similar speed glitches.

If there is any further advice you can provide, I'd be most grateful, but perhaps we should see what the other fmv's do first.

UPDATE 2:

I just got past the first major fmv involving Ocelot and the GRU, with no speed issues or glitches! ^_^ I'll keep you posted.

Update 3: I've just seen the whole big fmv involving Sokolov, the Boss, the mini nuke, injury etc, with no problems! I was even using msaa x2 AA in HWhacks! - but the aa might reduce smoothness a bit. It seems so far that only the opening fmv suffers from the frame drops. I also tested with 5x res, no msaa and got full fps except a couple of moments randomly.

Update 4: I've found i can play in-game with 4x and msaa 16x! This is with Nvidia cp boosts such as fxaa, anisotropic filtering 16x and 4 pre rendered frames. I think 5x could be achieved in-game without slow downs most of/maybe all of the time.

(Oh and, I just donated £5 to pcsx2, I know it's not much, but I'm glad to give something! It won't be the last either. ^_^)

Update 5:

I've just defeated "The End" sniper boss, and the fmv's since have seemed nearly always perfect. However the last fmv you see before fighting him suffered some slow down fluctuations. When I switched it to 3x (1920x1080) it was flawless. It's somewhat annoying, but not THE END of the world. I'll have to tinker with some settings to see if I can deal with the issues in 4x (2560x1440p.)

I've also noticed that sometimes when characters speak in some radio communique's there is a strange clicking behind their voices, but this is quite rare.

All comments, suggestions welcome.

All the best -

Myles Thomas
[Image: 310854_509464712448671_1230897346_n.jpg]
Reply




Users browsing this thread: 1 Guest(s)