Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mortal Kombat Armageddon - Scaling Problem
#1
Hey everybody.
I was playing the game and started messing around with pcsx2.
I wanted to see what the game would look like at 4xNative.
Apparently I got this as a result:
   
Before using preset scaling I was using a custom res of 2048x2048.
The game was looking like this:
   
My specs are in signature.
Any help would be appreciated.

NOTE:Tried it rightnow with latest buildbot beta and it still gives the same problem.
EDIT2Ohmypening FMV is looking fine but the main menu looks crappy from right side.
Here are the screens.
FMV 4xNative    
Main Menu 4xNAtive    
Using Pcsx2 SVN r 4918.
Intel E5700 @3.0Ghz,
Xfx Radeon 5670 1Gb,
4Gb DDR3 Ram,
Microsoft Windows7 Ultimate x86

Sponsored links

#2
Preset Scaling were always a bit buggy i guess. Each of them caused an glitch in one game or the other. Tongue



I play this game with an internal resolution of 2496 x 1533. My internal resolution looks quite fine to me.
[Image: recodersignature2.png]
#3
Known issue with multiplier scaling and the widescreen setting in that game, either disable widescreen or use native resolution.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#4
Widescreen doesn't seems to cause a problem in my compter.
[Image: recodersignature2.png]
#5
Nope it's actually set to stretch to window.
Intel E5700 @3.0Ghz,
Xfx Radeon 5670 1Gb,
4Gb DDR3 Ram,
Microsoft Windows7 Ultimate x86
#6
works fine here. Aspect Ratio and GSDX Ratio both in 4 : 3.
[Image: recodersignature2.png]
#7
The game's own widescreen video setting.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#8
Oops. Laugh
[Image: recodersignature2.png]
#9
My bad but still the game's widescreen setting is untouched.
Intel E5700 @3.0Ghz,
Xfx Radeon 5670 1Gb,
4Gb DDR3 Ram,
Microsoft Windows7 Ultimate x86
#10
Alright, so, I was having the same exact issue. I run the game at 4x scaling resolution, window settings Fit to Screen (which I maximize at 1920 x 1080 resolution), Direct3D 11 (Hardware), no speedhacks.

THE FIX: Once you reach the main menu, go into Options > Video and make sure Widescreen is set to off in the game, and TURN PROGRESSIVE MODE ON!.

After turning progressive mode on: http://i.imgur.com/zAzZBoW.png

The menu text is still a little glitchy looking, but I'm unsure of a fix for that. (Haven't tried anything other than setting VU clamping to Extra, which didn't fix it).
Intel Core i7-4790k 4.0 GHz
ASUS GeForce GTX 970 4GB STRIX
16GB of RAM
Windows 7 Home Premium SP1 x64




Users browsing this thread: 1 Guest(s)