Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 1.2.1 slows down in fps while playing
#1
Hey guys, can someone please help me out with this issue? I've been trying to get my pcsx2 running smoothly all day, but nothing helps. I checked a lot of youtube videos to get the right settings, but nothing seems to work. The main issue is keeping fps on a playable level. Mainly when there's a lot of action on the screen, or during cutscenes, it slows down a lot (audio goes very slow as well), sometimes it runs like it should, but then after a few seconds it slows down again.

I have a brand new computer, 16 GB Ram, 740M Nvidia Gforces graphics card, 1500GB hard drive, Intel Core 17 - 2.4 Ghz, so I don't think that's the problem.

My settings on the pcsx2 version 1.2.1:[Image: 33kr62q.png]

And here's a video (without sound though) where I'm playing a game on the emulator. You can see that it runs smoothly sometimes, but slows down in battle or when voice audio kicks in: http://youtu.be/w4Yz9QvBnr0

And the video is WITH Razer Game Booster. Without it, it's barely playable.

Edit: While browsing the forums, I noticed that some people are complaining about Ratchet and clank not being playable. Since I only tried Ratched and clank 1 & 3, that might be the main problem. I'll try another game.

Sponsored links

#2
Reported for piracy because there's no way you have 7 ps2
[Insert Witty Sig Here.]
#3
(05-03-2014, 11:18 PM)KeyToTruth12 Wrote: Reported for piracy because there's no way you have 7 ps2

That really helped me out.
#4
No further support will be given unless you can prove you have all of those ps2 (bios, technically)
[Insert Witty Sig Here.]
#5
(05-03-2014, 11:26 PM)KeyToTruth12 Wrote: No further support will be given unless you can prove you have all of those ps2 (bios, technically)

Had a bad day, sir?
#6
(05-03-2014, 11:27 PM)jehowi Wrote: Had a bad day, sir?

Have you ever read the rules?
[Insert Witty Sig Here.]
#7
Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)