Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PCSX2 for Debian/Ubuntu
Hi! 
After successful gaming on Kubuntu (17.04 x64) and easy installation with just sudo apt-get install pcsx2, a few day ago I installed KDE Neon over Kubuntu partition. It's Ubuntu LTS 16.04 with latest KDE Plasma 5.10. It is x64 4.8.0.53-generic kernel.

Now when I try to install pcsx2 I get:
Code:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Starting pkgProblemResolver with broken count: 5
Starting 2 pkgProblemResolver with broken count: 5
Investigating (0) libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libegl1-mesa:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.3.92)
 Considering libwayland-client0:i386 0 as a solution to libegl1-mesa:i386 1
 Holding Back libegl1-mesa:i386 rather than change libwayland-client0:i386
Investigating (0) libwayland-egl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libwayland-egl1-mesa:i386 Depends on libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (= 12.0.6-0ubuntu0.16.04.1)
 Considering libegl1-mesa:i386 1 as a solution to libwayland-egl1-mesa:i386 1
 Holding Back libwayland-egl1-mesa:i386 rather than change libegl1-mesa:i386
Investigating (0) libsdl2-2.0-0 [ i386 ] < none -> 2.0.4+dfsg1-2ubuntu2 > ( universe/libs )
Broken libsdl2-2.0-0:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.3.92)
 Considering libwayland-client0:i386 0 as a solution to libsdl2-2.0-0:i386 0
 Holding Back libsdl2-2.0-0:i386 rather than change libwayland-client0:i386
Investigating (0) libmirclient9 [ i386 ] < none -> 0.21.0+16.04.20160330-0ubuntu1 > ( libs )
Broken libmirclient9:i386 Depends on libxkbcommon0 [ i386 ] < none -> 0.5.0-1ubuntu2 > ( libs ) (>= 0.5.0)
 Considering libxkbcommon0:i386 0 as a solution to libmirclient9:i386 0
 Holding Back libmirclient9:i386 rather than change libxkbcommon0:i386
Investigating (0) libgtk-3-0 [ i386 ] < none -> 3.18.9-1ubuntu3.3 > ( libs )
Broken libgtk-3-0:i386 Depends on libmirclient9 [ i386 ] < none -> 0.21.0+16.04.20160330-0ubuntu1 > ( libs ) (>= 0.21.0+16.04.20160330)
 Considering libmirclient9:i386 0 as a solution to libgtk-3-0:i386 0
 Holding Back libgtk-3-0:i386 rather than change libmirclient9:i386
Investigating (0) libgbm1 [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libgbm1:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.2.0)
 Considering libwayland-client0:i386 0 as a solution to libgbm1:i386 0
 Holding Back libgbm1:i386 rather than change libwayland-client0:i386
Investigating (0) notification-daemon [ i386 ] < none -> 3.18.2-1 > ( x11 )
Broken notification-daemon:i386 Depends on libgtk-3-0 [ i386 ] < none -> 3.18.9-1ubuntu3.3 > ( libs ) (>= 3.16.2)
 Considering libgtk-3-0:i386 0 as a solution to notification-daemon:i386 0
 Holding Back notification-daemon:i386 rather than change libgtk-3-0:i386
Investigating (1) pcsx2 [ i386 ] < none -> 1.4.0+dfsg-1 > ( universe/games )
Broken pcsx2:i386 Depends on libsdl2-2.0-0 [ i386 ] < none -> 2.0.4+dfsg1-2ubuntu2 > ( universe/libs ) (>= 2.0.4)
 Considering libsdl2-2.0-0:i386 0 as a solution to pcsx2:i386 9999
   Reinst Failed because of libwayland-client0:i386
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pcsx2:i386 : Depends: libsdl2-2.0-0:i386 (>= 2.0.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Is it possible to overcome those issues? My kids are very unhappy now Sad I have already installed i386 multiarch.
Reply

Sponsored links

You have a dependency issue with SDL, wayland and EGL. I know one Ubuntu version got this issue, I don't know if anyone report an issue to Ubuntu.

First check that all mesa packages got the same version. Install any missing *egl*:i386 library
Code:
dpkg -l |grep -i mesa
Then check libwayland version. Be sure that i386 versions are installed too.
Code:
dpkg -l |grep -i libwayland

If you're all green try to install libsdl2-2.0-0:i386
Reply
dpkg -l | grep -i mesa 
Code:
ii  libegl1-mesa:amd64                              12.0.6-0ubuntu0.16.04.1                    amd64        free implementation of the EGL API -- runtime
ii  libgl1-mesa-dev:amd64                           12.0.6-0ubuntu0.16.04.1                    amd64        free implementation of the OpenGL API -- GLX development files
ii  libgl1-mesa-dri:amd64                           12.0.6-0ubuntu0.16.04.1                    amd64        free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-glx:amd64                           12.0.6-0ubuntu0.16.04.1                    amd64        free implementation of the OpenGL API -- GLX runtime
ii  libglapi-mesa:amd64                             12.0.6-0ubuntu0.16.04.1                    amd64        free implementation of the GL API -- shared library
ii  libgles2-mesa:amd64                             12.0.6-0ubuntu0.16.04.1                    amd64        free implementation of the OpenGL|ES 2.x API -- runtime
ii  libglu1-mesa:amd64                              9.0.0-2.1                                  amd64        Mesa OpenGL utility library (GLU)
ii  libglu1-mesa-dev:amd64                          9.0.0-2.1                                  amd64        Mesa OpenGL utility library -- development files
ii  libtxc-dxtn-s2tc0:amd64                         0~git20131104-1.1                          amd64        Texture compression library for Mesa
ii  libwayland-egl1-mesa:amd64                      12.0.6-0ubuntu0.16.04.1                    amd64        implementation of the Wayland EGL platform -- runtime
ii  mesa-common-dev:amd64                           12.0.6-0ubuntu0.16.04.1                    amd64        Developer documentation for Mesa
ii  mesa-utils                                      8.3.0-1                                    amd64        Miscellaneous Mesa GL utilities
ii  mesa-vdpau-drivers:amd64                        12.0.6-0ubuntu0.16.04.1                    amd64        Mesa VDPAU video acceleration drivers

dpkg -l | grep -i libwayland
Code:
ii  libwayland-client0:amd64                        1.12.0-1+16.04+build1                      amd64        wayland compositor infrastructure - client library
ii  libwayland-cursor0:amd64                        1.12.0-1+16.04+build1                      amd64        wayland compositor infrastructure - cursor library
ii  libwayland-egl1-mesa:amd64                      12.0.6-0ubuntu0.16.04.1                    amd64        implementation of the Wayland EGL platform -- runtime
ii  libwayland-server0:amd64                        1.12.0-1+16.04+build1                      amd64        wayland compositor infrastructure - server library



sudo apt-get install libsdl2-2.0-0:i386

Code:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Starting pkgProblemResolver with broken count: 3
Starting 2 pkgProblemResolver with broken count: 3
Investigating (0) libsdl2-2.0-0 [ i386 ] < none -> 2.0.4+dfsg1-2ubuntu2 > ( universe/libs )
Broken libsdl2-2.0-0:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.3.92)
 Considering libwayland-client0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libwayland-cursor0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.0.2)
 Considering libwayland-cursor0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libxkbcommon0 [ i386 ] < none -> 0.5.0-1ubuntu2 > ( libs ) (>= 0.5.0)
 Considering libxkbcommon0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Investigating (0) libgbm1 [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libgbm1:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.2.0)
 Considering libwayland-client0:i386 0 as a solution to libgbm1:i386 0
 Holding Back libgbm1:i386 rather than change libwayland-client0:i386
Investigating (0) libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libegl1-mesa:i386 Depends on libgbm1 [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (= 12.0.6-0ubuntu0.16.04.1)
 Considering libgbm1:i386 0 as a solution to libegl1-mesa:i386 0
 Holding Back libegl1-mesa:i386 rather than change libgbm1:i386
Investigating (1) libsdl2-2.0-0 [ i386 ] < none -> 2.0.4+dfsg1-2ubuntu2 > ( universe/libs )
Broken libsdl2-2.0-0:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.3.92)
 Considering libwayland-client0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libwayland-cursor0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.0.2)
 Considering libwayland-cursor0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libxkbcommon0 [ i386 ] < none -> 0.5.0-1ubuntu2 > ( libs ) (>= 0.5.0)
 Considering libxkbcommon0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Investigating (1) libwayland-egl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libwayland-egl1-mesa:i386 Depends on libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (= 12.0.6-0ubuntu0.16.04.1)
 Considering libegl1-mesa:i386 0 as a solution to libwayland-egl1-mesa:i386 0
 Holding Back libwayland-egl1-mesa:i386 rather than change libegl1-mesa:i386
Investigating (2) libsdl2-2.0-0 [ i386 ] < none -> 2.0.4+dfsg1-2ubuntu2 > ( universe/libs )
Broken libsdl2-2.0-0:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.3.92)
 Considering libwayland-client0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libwayland-cursor0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.0.2)
 Considering libwayland-cursor0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libwayland-egl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (>= 10.0.2)
 Considering libwayland-egl1-mesa:i386 0 as a solution to libsdl2-2.0-0:i386 9999
   Reinst Failed because of libwayland-client0:i386
   Reinst Failed because of libgbm1:i386
   Reinst Failed because of libegl1-mesa:i386
 Considering libwayland-egl1-mesa:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libwayland-egl1 [ i386 ] < none ->  > ( none )
 Considering libwayland-egl1-mesa:i386 0 as a solution to libsdl2-2.0-0:i386 9999
 Considering libwayland-egl1-mesa:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Broken libsdl2-2.0-0:i386 Depends on libxkbcommon0 [ i386 ] < none -> 0.5.0-1ubuntu2 > ( libs ) (>= 0.5.0)
 Considering libxkbcommon0:i386 0 as a solution to libsdl2-2.0-0:i386 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsdl2-2.0-0:i386 : Depends: libwayland-client0:i386 (>= 1.3.92) but it is not going to be installed
                     Depends: libwayland-cursor0:i386 (>= 1.0.2) but it is not going to be installed
                     Depends: libwayland-egl1-mesa:i386 (>= 10.0.2) but it is not going to be installed or
                              libwayland-egl1:i386
                     Depends: libxkbcommon0:i386 (>= 0.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reply
First you should manually install libwayland and mesa i386 packages.
Code:
sudo apt install libwayland-client0:i386 libwayland-cursor0:i386  libwayland-egl1-mesa:i386  libwayland-server0:i386

Edit: Be aware to not remove your desktop
Reply
(06-02-2017, 12:24 PM)gregory Wrote: First you should manually install libwayland and mesa i386 packages.
Code:
sudo apt install libwayland-client0:i386 libwayland-cursor0:i386  libwayland-egl1-mesa:i386  libwayland-server0:i386

Edit: Be aware to not remove your desktop

Can I even continue without not removing my desktop. I was asked to confirm this:

Code:
The following packages will be REMOVED:
 ark baloo-kf5 bluedevil breeze dolphin firefox frameworkintegration gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad
 gstreamer1.0-plugins-bad-videoparsers gwenview indicator-application kaccounts-providers kactivitymanagerd kamera kde-cli-tools kde-config-gtk-style
 kde-config-gtk-style-preview kde-config-plymouth kde-config-screenlocker kde-config-sddm kde-spectacle kde-style-breeze kde-style-breeze-qt4 kdeconnect
 kded5 kdialog kgamma5 khotkeys kimageformat-plugins kinfocenter kinit kio kio-extras kmenuedit konsole konsole-kpart kpackagelauncherqml krdc kross kscreen
 ksshaskpass ksysguard ktexteditor-katepart kwalletmanager kwayland-integration kwin kwin-addons kwin-common kwin-data kwin-style-breeze kwin-x11 kwrite
 kwrited libappindicator3-1 libdebconf-kde1 libegl1-mesa libgbm1 libgstreamer-plugins-bad1.0-0 libgtk-3-0 libgtk-3-bin libindicator3-7 libkaccounts1
 libkdecorations2-5v5 libkdecorations2private5v5 libkf5auth5 libkf5baloo5 libkf5baloowidgets5 libkf5bookmarks5 libkf5completion5 libkf5configgui5
 libkf5configwidgets5 libkf5crash5 libkf5dbusaddons5 libkf5declarative5 libkf5emoticons-bin libkf5emoticons5 libkf5filemetadata-bin libkf5globalaccel-bin
 libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5 libkf5iconthemes-bin libkf5iconthemes5 libkf5idletime5 libkf5itemviews5 libkf5jobwidgets5
 libkf5jsembed5 libkf5kcmutils5 libkf5kdcraw5 libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kexiv2-15.0.0 libkf5khtml-bin libkf5khtml5
 libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiowidgets5 libkf5kipi32.0.0 libkf5krosscore5 libkf5krossui5 libkf5newstuff5 libkf5newstuffcore5
 libkf5notifications5 libkf5notifyconfig5 libkf5parts-plugins libkf5parts5 libkf5people5 libkf5peoplewidgets5 libkf5plasma5 libkf5plasmaquick5 libkf5prison5
 libkf5purpose5 libkf5purposewidgets5 libkf5quickaddons5 libkf5runner5 libkf5screen7 libkf5service-bin libkf5service5 libkf5solid5 libkf5sonnetui5
 libkf5style5 libkf5su-bin libkf5su5 libkf5syntaxhighlighting5 libkf5sysguard-bin libkf5texteditor5 libkf5textwidgets5 libkf5wallet-bin libkf5wallet5
 libkf5waylandclient5 libkf5waylandserver5 libkf5widgetsaddons5 libkf5windowsystem5 libkf5xmlgui5 libkf5xmlrpcclient5 libkfontinstui5 libkscreenlocker5
 libksignalplotter7 libkwalletbackend5-5 libkwin4-effect-builtins1 libkwineffects11 libkwinglutils11 libkwinxrenderutils11 libkworkspace5-5 libokular5core7
 libphonon4qt5-4 libpolkit-qt5-1-1 libpoppler-qt5-1 libpowerdevilcore2 libprocessui7 libqapt3-runtime libqgsttools-p1 libqmobipocket2 libqt5designer5
 libqt5designercomponents5 libqt5gui5 libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5opengl5
 libqt5opengl5-dev libqt5printsupport5 libqt5quick5 libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5quickwidgets5 libqt5svg5 libqt5waylandclient5
 libqt5waylandcompositor5 libqt5webkit5 libqt5widgets5 libqt5x11extras5 libscim8v5 libtaskmanager6 libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa
 libwayland-server0 libweather-ion7 libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-37-gtk2 milou muon-notifier muon-updater neon-desktop notification-daemon okular
 phonon-backend-vlc phonon4qt5 phonon4qt5-backend-vlc plasma-dataengines-addons plasma-desktop plasma-discover plasma-discover-private
 plasma-discover-updater plasma-framework plasma-integration plasma-nm plasma-pa plasma-runners-addons plasma-wallpapers-addons plasma-widgets-addons
 plasma-workspace polkit-kde-agent-1 powerdevil print-manager qapt-deb-installer qml-module-org-kde-activities qml-module-org-kde-draganddrop
 qml-module-org-kde-extensionplugin qml-module-org-kde-kconfig qml-module-org-kde-kcoreaddons qml-module-org-kde-kio qml-module-org-kde-kirigami
 qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem
 qml-module-org-kde-newstuff qml-module-org-kde-purpose qml-module-org-kde-runnermodel qml-module-org-kde-solid qml-module-qtgraphicaleffects
 qml-module-qtmultimedia qml-module-qtquick-controls qml-module-qtquick-controls-styles-breeze qml-module-qtquick-controls2 qml-module-qtquick-dialogs
 qml-module-qtquick-layouts qml-module-qtquick-privatewidgets qml-module-qtquick-templates2 qml-module-qtquick-virtualkeyboard qml-module-qtquick-window2
 qml-module-qtquick2 qml-module-qtwebkit qml-module-ubuntu-onlineaccounts qt5-default qt5-gtk-platformtheme qt5-image-formats-plugins qtbase5-dev
 qtdeclarative5-qtquick2-plugin qttools5-dev-tools qtvirtualkeyboard qtwayland5 sddm sddm-theme-breeze steam-launcher systemsettings user-manager vlc
 xdg-desktop-portal-kde xorg xserver-xorg-core-hwe-16.04 xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04 xserver-xorg-input-evdev-hwe-16.04
 xserver-xorg-input-synaptics-hwe-16.04 xserver-xorg-input-wacom-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-video-amdgpu-hwe-16.04
 xserver-xorg-video-ati-hwe-16.04 xserver-xorg-video-fbdev-hwe-16.04 xserver-xorg-video-nouveau-hwe-16.04 xserver-xorg-video-qxl-hwe-16.04
 xserver-xorg-video-radeon-hwe-16.04 xserver-xorg-video-vesa-hwe-16.04 xserver-xorg-video-vmware-hwe-16.04 ysoft-client zenity

Which I refused and aborted the installation.
Reply
There is multiarch depency bug in a package. I don't remember if the bug is the wayland packages or the EGL/mesa packages.
You can check a package when you try to install both arch.
Code:
sudo apt install libwayland-client0:i386  libwayland-client0:amd64
sudo apt install libwayland-egl1-mesa:i386  libwayland-egl1-mesa:amd64

I don't know Ubuntu very well but Debian have an "update" repository. Maybe you can get somewhere newer Mesa or Wayland packages.
Reply
(06-02-2017, 02:41 PM)gregory Wrote: There is multiarch depency bug in a package. I don't remember if the bug is the wayland packages or the EGL/mesa packages.
You can check a package when you try to install both arch.
Code:
sudo apt install libwayland-client0:i386  libwayland-client0:amd64
sudo apt install libwayland-egl1-mesa:i386  libwayland-egl1-mesa:amd64

I don't know Ubuntu very well but Debian have an "update" repository. Maybe you can get somewhere newer Mesa or Wayland packages.

sudo apt install libwayland-client0:i386  libwayland-client0:amd64

Code:
Reading package lists... Done
Building dependency tree        
Reading state information... Done
libwayland-egl1-mesa is already the newest version (12.0.6-0ubuntu0.16.04.1).
libwayland-egl1-mesa set to manually installed.
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) libgbm1 [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libgbm1:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.2.0)
 Considering libwayland-client0:i386 0 as a solution to libgbm1:i386 0
 Holding Back libgbm1:i386 rather than change libwayland-client0:i386
Investigating (0) libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libegl1-mesa:i386 Depends on libgbm1 [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (= 12.0.6-0ubuntu0.16.04.1)
 Considering libgbm1:i386 0 as a solution to libegl1-mesa:i386 0
 Holding Back libegl1-mesa:i386 rather than change libgbm1:i386
Investigating (1) libwayland-egl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libwayland-egl1-mesa:i386 Depends on libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (= 12.0.6-0ubuntu0.16.
04.1)
 Considering libegl1-mesa:i386 0 as a solution to libwayland-egl1-mesa:i386 9999
   Reinst Failed because of libwayland-client0:i386
   Reinst Failed because of libgbm1:i386
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libwayland-egl1-mesa:i386 : Depends: libegl1-mesa:i386 (= 12.0.6-0ubuntu0.16.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt install libwayland-egl1-mesa:i386  libwayland-egl1-mesa:amd64

Code:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libwayland-egl1-mesa is already the newest version (12.0.6-0ubuntu0.16.04.1).
libwayland-egl1-mesa set to manually installed.
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) libgbm1 [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libgbm1:i386 Depends on libwayland-client0 [ i386 ] < none -> 1.9.0-1 > ( libs ) (>= 1.2.0)
 Considering libwayland-client0:i386 0 as a solution to libgbm1:i386 0
 Holding Back libgbm1:i386 rather than change libwayland-client0:i386
Investigating (0) libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libegl1-mesa:i386 Depends on libgbm1 [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (= 12.0.6-0ubuntu0.16.04.1)
 Considering libgbm1:i386 0 as a solution to libegl1-mesa:i386 0
 Holding Back libegl1-mesa:i386 rather than change libgbm1:i386
Investigating (1) libwayland-egl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs )
Broken libwayland-egl1-mesa:i386 Depends on libegl1-mesa [ i386 ] < none -> 12.0.6-0ubuntu0.16.04.1 > ( libs ) (= 12.0.6-0ubuntu0.16.04.1)
 Considering libegl1-mesa:i386 0 as a solution to libwayland-egl1-mesa:i386 9999
   Reinst Failed because of libwayland-client0:i386
   Reinst Failed because of libgbm1:i386
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libwayland-egl1-mesa:i386 : Depends: libegl1-mesa:i386 (= 12.0.6-0ubuntu0.16.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have 'updates' main, universe and multiuniverse repos enabled. Could you help and tell me what to report to Canonical?
Reply
Report a multiarch depencency issue.

If you can't install libegl1 (cmd below), report it to mesa package.
Code:
sudo apt install libegl1-mesa:i386  libegl1-mesa:amd64

Hum, your version of Mesa is quite old, so maybe there is a newer package somewhere (sorry I don't know Ubuntu in detail).
Reply




Users browsing this thread: 1 Guest(s)