Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3 60 to 20 frames (not classroom related)
#1
*contains minor spoiler*


Hi

I can play Persona 3 on constant 60 fps for a changeing amount of time and then theres some point where the game just seems to "break" and it doesn't get over 25fps anymore.


This seems to happen at random though there are some points where it appears to be more likely to happen EXAMPLE:
I start the game and play to the point where you can ask the first question (Why do you have a gun etc..) then i go afk and when i return it's down to 20fps or..
generally around the time in the middle of faculty office (restarded pretty often and it usually broke around here) or..
i somehow managed to get to the 1st savepoint then restarted the game to increase speed hacks. Then continued playing and it broke when akihara calls and says he's being followed by a monster even though i was able to play through the same "screen" in an earlier scene.

I still lost a couple of fps (45-50) in the the auditorium and classroom scene at the time when i managed to get to the 1st save point



My PC: AMD Quadcore (can't remember which one shame on me i know.. works fine with FFX and Persona 4)
GeForce 9600GT 512 Mb
4000MB DDR ram

My PCSX2:0.9.7 and an older beta-1190 (0.9.6 didn't work well at all)
Gsdx 0.1.16 SSE2 (r3068)
SPU2-X 1.4.0 (r3117)
cdvd Gigaherz 0.8.0 (r3006)
(tried others/older versions too)
Windows XP 32

Gsdx config: Direct3D9 Hardware (tried software too)
internal res: 1280:768 (widescreen) also tried 1920:1080 at the beginning and it also worked as good as lower res.
Texture filtering/Logarithmic Z/8bit textures/Alpha correction enabled
Everything else turned off

Fixes/Hacks:
first thing to notice is that i played around with these A LOT! and i came to the conclusion that neither EE Cyclerate nor VU Cycle Stealing is the problem though i still might just be retarded...
edit: i tried using no hacks at all but the problems still there...

All hacks enabled except mVUMin/Max Hack
Persona VU Clip Flag Hack enabled (though VU0 and VU1 are on micro VU Recompiler) tried it with or without fix obviously didn't make any difference
edit: running it with super VU recompiler on VU0 and VU1 now (..same problem)

I left all other options in EE/IOP + VUs + GS as they were after install.

I tried running directly from drive and from an iso


I tried similar things with the earlier beta version of Pcsx2 which i mentioned above



I've been trying to get this lil' sucker to work for about 5 hours now and I'd appreciate any advise :/

(didn't find anything similar in other P3 threads)..

Edith says:useing native resolution is not playable for me due to obvious reasons
Edith says more: I use the same settings as sporked in this post:
http://forums.pcsx2.net/Thread-Persona-3...=persona+3

except i have super VU compiler on both VU0 and VU1
and as mentioned above i already tried disableing all speedhacks

which means it should be a problem with my system...?!
Reply

Sponsored links

#2
First make doubly sure that vsync is disabled in both, PCSX2 configuration and your graphic card driver panel.
Reply
#3
(07-05-2010, 05:03 PM)rama Wrote: First make doubly sure that vsync is disabled in both, PCSX2 configuration and your graphic card driver panel.

doubly checked it on pcsx2 wait for vsync is off
vsync in my graphic card configuration was on "active for 3D applications" turned it to automatic off

will try again now
Reply
#4
nope didn't solve the problem...
occured this time shortly after the 1st battle when you wake up
Reply
#5
Okay, so can you explain a bit better how this happens?
Are you getting an unlimted frame rate of like 73FPS, then all of a sudden it drops to 20?
Reply
#6
(07-05-2010, 07:44 PM)rama Wrote: Are you getting an unlimted frame rate of like 73FPS, then all of a sudden it drops to 20?

in short - yes -



i just tried running it with disabled frameratelimiting and got about 70 fps in conversation and over 100 while walking around

though i usually use frame limiter with 60fps pal and i can run these settings even on very high internal resolution without dropping for some time and..
then all of a sudden the frames just crash and the framerate never goes back up over 20 fps unless i restart the pcsx2

the thing that bugs me the most is the randomness.. it's more like it crashes after a certain amount of time or received data or i dunno... i seem to be able to pass spots around which the game usually breaks by quickly skipping through everything that happens before i get there though this might just be my imagination...
ohh yeah and it has always happened in dialog so far ... then again theres almost nothing except dialog in P3 at the beginning..
Reply
#7
Seems like some kind of throttling. Try checking the CPU clock speed and temperatures while you're playing and when you get the slowdowns with an app like CoreTemp.

And try disabling any kind of powersaving features like Cool-n-Quiet
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
(07-05-2010, 08:26 PM)Shadow Lady Wrote: Seems like some kind of throttling. Try checking the CPU clock speed and temperatures while you're playing and when you get the slowdowns with an app like CoreTemp

No cool and quiet stuff where i come from Laugh

anyways you're probably right about the temperature...
My Graphic Card's fan is doing absolutely nothing -.- i tried forcing it with rivatuner but had no success so it's probably screwed...

why does ***** like this always have to happen when you have no cash and you've got holidays >_<
I'll buy a new fan tomorrow and come back if it still doesn't work...



Thanks a bunch the fan would've been the last place i would've gone looking!
Reply




Users browsing this thread: 1 Guest(s)