Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random crashing...
#1
PCSX2 1.3.1-20150923092624 - compiled on Sep 23 2015
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 10240), 64-bit
Physical RAM     =  8073 MB
CPU name         =  Intel® Core™ i7-2600K CPU @ 3.40GHz
Vendor/Model     =  GenuineIntel (stepping 07)
CPU speed        =  3.398 ghz (8 logical threads)

BIOS:  USA v2.20 (10/02/2006)
GS:  GSdx 0 (MSVC 18.00, SSSE3) 0.1.16 [gsdx32-ssse3-r5875]
PAD:  Pokopom XInput Pad Plugin 2.1.0 [padPokopom]
SPU2:  SPU2-X 2015090221803 2.0.0 [SPU2-X]
All other plugins are default settings. 
[Image: 59e406751c.png]
I use Pokopom XInput because I'm using an XBOX 360 Controller to play.
Also, I run Hardware rendering unless a game specifically requires Software rendering on the wikia.


Video Plugin Settings:
  [Image: fe9e8f9a88.png]
Audio Plugin Settings:  
[Image: 7022c86314.png]
The problem I'm having is that even on an SVN build, PCSX2 randomly crashes on numerous games. I played through Dark Cloud with no issues at all. A full 30 hour playthrough without a single crash. Now, most games seem to crash and I have no idea why.. God of War, Need for Speed:  Most Wanted, Spawn Armageddon, Maximo:  Ghosts to Glory, etc. 
They run fine for any length of time before crashing randomly. If I missed any important information, please let me know.. or if I posted in the wrong spot.
Thanks!

EDIT: Nvidia GTX 750ti
Reply

Sponsored links

#2
Try switching the audio module from xaudio2 to portaudio. You may have to hit the configure button in spu2x and tick the box for wasapi exclusive mode
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
(09-28-2015, 02:41 AM)Nobbs66 Wrote: Try switching the audio module from xaudio2 to portaudio. You may have to hit the configure button in spu2x and tick the box for wasapi exclusive mode

I tried that, but an issue I have with that setting personally is that I can't hear anything else on my PC. I normally chat with some friends on Teamspeak 3 while I play.
I don't think that has anything to do with my crashing though (TS3). I played through Dark Cloud without an issue while talking to friends, etc.

Could it really be a sound plugin causing the crashes? PCSX2 is scary for someone like me who isn't much of a tech genius.. But I've been trying to learn how to operate this thing without asking for help.. I had to finally grow a pair and ask here because I've not been able to fix the crashing myself after a week now.
Reply
#4
Yeah, xaudio2 can definitely have crashes. If portaudio doesn't suit your needs, then try direct audio
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#5
(09-28-2015, 03:08 AM)Nobbs66 Wrote: Yeah, xaudio2 can definitely have crashes. If portaudio doesn't suit your needs, then try direct audio

I tried option 2 DirectSound on Wrath Unleashed, and my game crashed on the intros after audio skipped a ton. So I'm not sure if that'll work.
Reply
#6
switch back to xaudio2 for a bit. if it crashes, don't re open the emu, but just go to pcsx2>logs and post the emulog.txt here.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#7
EDIT:  This is with all settings that were mentioned in the initial post. Same audio/video settings. Nothing has changed!
EDIT 2: I am booting from iso files, not directly from CDs.

Okay. So.. for the purpose of testing.. I opened NFS Most Wanted (which is one of many games that seems to crash) and went AFK while on the main menu. When I came back after 30 minutes or so, it had crashed.

Here is the log... I don't understand any of it. Am I doing something wrong?

PCSX2 1.3.1-20150923092624 - compiled on Sep 23 2015
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 10240), 64-bit
Physical RAM     =  8073 MB
CPU name         =  Intel® Core™ i7-2600K CPU @ 3.40GHz
Vendor/Model     =  GenuineIntel (stepping 07)
CPU speed        =  3.399 ghz (8 logical threads)
x86PType         =  Standard OEM
x86Flags         =  bfebfbff 1f9ae3bf
x86EFlags        =  28100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding   GS: C:\Program Files (x86)\PCSX2 1.2.1\plugins\gsdx32-ssse3-r5875.dll
Windows 10.0.10240
Binding  PAD: C:\Program Files (x86)\PCSX2 1.2.1\plugins\padPokopom.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\plugins\SPU2-X.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\plugins\cdvdGigaherz.dll
Binding  USB: C:\Program Files (x86)\PCSX2 1.2.1\plugins\USBnull.dll
Binding   FW: C:\Program Files (x86)\PCSX2 1.2.1\plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9691 games on record (loaded in 161ms)
HotSwapping to new ISO src image!
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 10.0.10240
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\WorldGenocideX\Desktop\PS2\Need for Speed - Most Wanted - Black Edition\Need for Speed - Most Wanted.iso
Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1808064 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0 [File]: C:\Program Files (x86)\PCSX2 1.2.1\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Program Files (x86)\PCSX2 1.2.1\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA     v02.20(10/02/2006)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.70, ctm:392Mhz, cpuclk:294Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2006-0210, IOP info (CPUID=1f, CACH_CONFIG=14000200, 2MB, IOP mode)
<20060210-142424,ROMconf,PS20220WC20060210.bin:11824>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Apr  7 2005 21:09:14
 CPUID=2e20, BoardID=0, ROMGEN=2006-0210, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.51;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_213.51;1) Game CRC = 0x0518D274, EntryPoint = 0x00436128
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.51;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
Reply
#8
Does anyone have a clue as to what's wrong?
Reply
#9
Is pcsx2 completely shut down or is just the emulation stopped?
Can you please monitor ram usage?
Please check windows eventviewer for error warning or critical messages at times when pcsx2 dies.
Can you please make the same benchmark (NFS menu) using portaudio?


BTW. What happens if you don't use exclusive mode or portaudio?
Reply
#10
change to PortAudio instead of xaudio2 or Directsound and try that, it is the new preferred output engine. If you get no sound hit the "configure" button underneath where you choose the output module and tick "exclusive mode"

Also Audio is skipping a ton because you have spu2-x set to "async mix", change it to Timestretch and it will be much better.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)