Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ratchet and Clank
#1
I know these games are very demanding.
Also My Computer Isn't The Best, But istill able to run some games at full speed in software mode:
Core i5 3470 3.20 Ghz
8GB Ram
Geforce GTX 660 2GB
Windows 7 64Bit
I use the latest official release (1.00 r5350). after enabling the mtvu speed hack, and all the others recommended speed hacks, and using software mode with 3 extra rendering threads (gsdx directx 11) it ran at full speed (50 fps), but when there were many enemies on screen, the fps droped, 37-45 fps. Is there anyway I can play them without slowdown, or with little slowdown only (not hardware mode)?
Sorry for my bad english
Reply

Sponsored links

#2
If you aren't limited(reaching 100%) by EE% without MTvu, then you should disable it, generally even if you need it for one or two fps you should disable it since this hack depending on game wastes from some to alot of extra cpu power just to synchronize the new thread. Hence disabling it "might" give that extra power back to those software rendering threads(you might even experiment with other number of them). As long as slider speedhacks doesn't break or slow the game down you might also experiment with them at least a bit to free up some cpu power pcsx2 side which can then be used in gsdx.

Other than that you can only turn off any other stuff which might hug your cpu ~ like web browser or any extra programs you are running and/or OC your cpu(which might not be much since it's non K ~ locked model), not really much else to do.
Reply
#3
I tried many extra rendering threads options, and 3 was the best option.
Now I will disable the mtvu and check if it helps.
Edit: I disabled the MTVU Speed Hack, but unfortunately, it Didn't help. the fps was lower.
Is There anything else I can do? cause the other speedd hacks showed false fps reading, and made the games even slower
Reply
#4
Experiment with EE timing and VU cycle stealing. Ratchet and Clank is a notoriusly difficult game and highly requested for support due to fps problems. Your system is good, it's too bad you don't have the k version.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#5
the ee and vu stealing didn't help, in fact it made it even worse.
the fps drops were only when there were many enemies on screen.
so there is nothing I can do, except from upgrading my cpu or overclocking it (won't happen anytime soon)?
Edit: My gxdx plugin is avx r5334 (the one that comes with version 1.00). is there a faster gsdx plugin?
Reply
#6
You can try svn one if you didn't, but most likely only AVX2 version could be slightly faster and that's reserved for Haswell cpu's.

You could try frameskipping(config>emulation settings>GS) althrough I have no clue how it work with this game, typically it's pretty bad and to begin with you have to find values to draw and skip that'll not break your game since that's common;p. This will easily cut GS usage efffectively speeding up your game, at the cost of lower framerate, you might set a turbo value for 100% and activate frameskipping only on turbo so you can only switch it for whenever you get slowdowns. But if you can't live with lower framerate at those currently laggy scenes or if frameskip is too buggy for this game then pretty much wait with this game till you get something better.
Reply
#7
Tried different direct3d renderes ?
ticked-unticked allow 8 bit textures ?
playing from dvd or iso ?
tried clamping & round modes to nearest,none in emulation settings ?
edge anti-aliasing ticked or unticked in video settings ?
Reply
#8
OK, I wiil hust wait to an newer version or plugins, thank you all.
Reply
#9
(07-18-2013, 03:26 PM)Preet Wrote: Tried different direct3d renderes ?
ticked-unticked allow 8 bit textures ?
playing from dvd or iso ?
tried clamping & round modes to nearest,none in emulation settings ?
edge anti-aliasing ticked or unticked in video settings ?

Sorry, I didn't see your comment.
I Tried Also AVX R5649 and R5702, but it wasn't better.
I used software mode, and unticked edge anti-aliasing (When I ticked it, there was no change in the fps).
Reply
#10
GSDX version has nothing to do with your slowdowns, your CPU is simply too slow for this game. It's easily one of the most demanding games to emulate.
[Image: 2748844.png]
Reply




Users browsing this thread: 1 Guest(s)