Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rumble Roses Crashes the Emulator GDSX Hardware Startup
#1
SLUS-20970 crashes the emulator on startup when in hardware mode. In software mode, it starts up. After you see something in software mode, it is okay to put it back in hardware mode and it will work fine.

Here is the windows error message:

Code:
Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    pcsx2-r5710.exe
  Application Version:    0.0.0.0
  Application Timestamp:    51f6a658
  Fault Module Name:    GSdx32-AVX-r5709.dll
  Fault Module Version:    1.0.1.9
  Fault Module Timestamp:    51f6a970
  Exception Code:    c0000005
  Exception Offset:    0001e7e3
  OS Version:    6.1.7601.2.1.0.768.3
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

Plugins and Settings:

Code:
GS=GSdx32-AVX-r5709.dll
PAD=padPokopom.dll
SPU2=SPU2-X-r5695.dll
CDVD=cdvdGigaherz-r5692.dll
USB=USBnull-r5684.dll
FW=FWnull-r5684.dll
DEV9=DEV9null-r5684.dll

[EmuCore]
CdvdVerboseReads=disabled
CdvdDumpBlocks=disabled
EnablePatches=enabled
EnableCheats=disabled
ConsoleToStdio=disabled
HostFs=disabled
BackupSavestate=enabled
McdEnableEjection=enabled
MultitapPort0_Enabled=disabled
MultitapPort1_Enabled=disabled
[EmuCore/Speedhacks]
EECycleRate=1
VUCycleSteal=0
fastCDVD=enabled
IntcStat=enabled
WaitLoop=enabled
vuFlagHack=enabled
vuThread=enabled
[EmuCore/CPU]
FPU.DenormalsAreZero=enabled
FPU.FlushToZero=enabled
FPU.Roundmode=3
VU.DenormalsAreZero=enabled
VU.FlushToZero=enabled
VU.Roundmode=3
[EmuCore/CPU/Recompiler]
EnableEE=enabled
EnableIOP=enabled
EnableEECache=disabled
EnableVU0=enabled
EnableVU1=enabled
UseMicroVU0=enabled
UseMicroVU1=enabled
vuOverflow=enabled
vuExtraOverflow=disabled
vuSignOverflow=disabled
vuUnderflow=disabled
fpuOverflow=enabled
fpuExtraOverflow=disabled
fpuFullMode=disabled
StackFrameChecks=disabled
PreBlockCheckEE=disabled
PreBlockCheckIOP=disabled
[EmuCore/GS]
SynchronousMTGS=disabled
DisableOutput=disabled
VsyncQueueSize=2
FrameLimitEnable=enabled
FrameSkipEnable=disabled
VsyncEnable=enabled
ManagedVsync=enabled
LimitScalar=1.00
FramerateNTSC=59.94
FrameratePAL=50.00
DefaultRegionMode=ntsc
FramesToDraw=2
FramesToSkip=2
[EmuCore/Gamefixes]
VuAddSubHack=disabled
VuClipFlagHack=disabled
FpuCompareHack=disabled
FpuMulHack=disabled
FpuNegDivHack=disabled
XgKickHack=disabled
IPUWaitHack=disabled
EETimingHack=disabled
SkipMPEGHack=disabled
OPHFlagHack=disabled
DMABusyHack=disabled
VIFFIFOHack=enabled
VIF1StallHack=disabled
GIFReverseHack=disabled
FMVinSoftwareHack=disabled
[EmuCore/Profiler]
Enabled=disabled
RecBlocks_EE=enabled
RecBlocks_IOP=enabled
RecBlocks_VU0=enabled
RecBlocks_VU1=enabled
[EmuCore/TraceLog]
Enabled=disabled
EE.bitset=0
IOP.bitset=0

[Settings]
ShadeBoost_Contrast=50
ShadeBoost_Brightness=50
ShadeBoost_Saturation=50
ModeWidth=1920
ModeHeight=1080
ModeRefreshRate=120
Renderer=3
Interlace=7
AspectRatio=0
upscale_multiplier=1
windowed=1
filter=0
paltex=0
vsync=0
logz=1
fba=1
aa1=0
fxaa=1
nativeres=0
resx=1920
resy=1080
extrathreads=5
ShadeBoost=0
UserHacks=0
UserHacks_MSAA=0
UserHacks_AlphaHack=0
UserHacks_HalfPixelOffset=0
UserHacks_SpriteHack=0
UserHacks_SkipDraw=1
UserHacks_WildHack=0
UserHacks_AggressiveCRC=1
UserHacks_AlphaStencil=0
UserHacks_DisableCrcHacks=0
Adapter=default
UserHacks_TCOffset=32768500
Model: Clevo P570WM Laptop
GPU: GeForce GTX 980M ~8GB GDDR5
CPU: Intel Core i7-4960X CPU +4.2GHz (12 CPUs)
Memory: 32GB Corsair Vengeance DDR3L 1600MHz, 4x8gb
OS: Microsoft Windows 7 Ultimate
Reply

Sponsored links

#2
You could try using native multiplier res instead of custom one(ie x3 or x4 instead of 1920x1080) as GSdx seems to have problems at some games with shaders+custom res resulting with a crash at boot time.
Reply
#3
All of the native res multipliers work. Thanks.
BTW, choosing shutdown crashes the emulator when doing it this way though. Also, it does this without shaders as well.
Model: Clevo P570WM Laptop
GPU: GeForce GTX 980M ~8GB GDDR5
CPU: Intel Core i7-4960X CPU +4.2GHz (12 CPUs)
Memory: 32GB Corsair Vengeance DDR3L 1600MHz, 4x8gb
OS: Microsoft Windows 7 Ultimate
Reply
#4
Frankly I never used "shutdown" myself for as long as I'm using pcsx2(and it's quite some time and not limited to just playing either;p), if you want to leave pcsx2, you can just close it normally no reason to use shutdown earlier. Unless you have to use it to avoid some other unknown problems this feature is pretty obsolete.

Anyway tried it and with native multiplier res + shaders ~ nothing happened and I did try on a game that crashes on boot when using shaders+custom res(+few others), I don't have RR to try through and use only SSE2, so might be limited to this game or related to AVX version of the plugin. Another case of strange problems aka welcome to emulation *sigh*. ;o
Reply




Users browsing this thread: 1 Guest(s)