Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stuttering on Gran Turismo 4
#1
I wanted to try and play Gran Turismo 4 again after I saw that almost all the bugs with it had been fixed in the OGL renderer but as soon as I use anything above native resolution the game starts having small seizures somewhat often, I tried quite a lot of things but I can only seem to slightly reduce it or make it way worse.

Obviously I can make it totally go away by just using the DX11 renderer but it also has a whole host of problems of it's own (namely making the game way darker in races and forcing me to switch back to the software renderer at the start of every race if I don't want PCSX2 to freeze for half a minute each time)

Is there a known fix I'm not aware of or is it not a problem I can fix on my side of things?

Specs:
Win 7 x64
4770k @ 4.3Ghz
GTX 770 4GB @ stock with 365.19 drivers
Reply

Sponsored links

#2
Make sure you are using the latest Git build, there has been a lot of fixes which help GT4 in OpenGL since the 1.4.0 release.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
I played game a lot on 1.40 it was working very good, not a single crash anywhere, not even licences, no lags no freezing either.
Just select 480p in options of game and put brightness to 0.
480p option doesnt get saved so if u restart emulator u have to do that again.

--
can't say about git, havent tested there yet.

P.S
I just tried OGL on latest git, it would crash emulator for me once entered race, with error that its asking more memory then gpu has.. Tongue 2gb gpu (scaling x2)
Reply
#4
(06-11-2016, 01:24 AM)refraction Wrote: Make sure you are using the latest Git build, there has been a lot of fixes which help GT4 in OpenGL since the 1.4.0 release.
I forgot to mention it but I was already using a pretty recent build (v1.5.0-dev-869-ge6e8e2e).

(06-11-2016, 01:26 AM)IcemanSR Wrote: I played game a lot on 1.40 it was working very good, not a single crash anywhere, not even licences, no lags no freezing either.
Just select 480p in options of game and put brightness to 0.
480p option doesnt get saved so if u restart emulator u have to do that again.

--
can't say about git, havent tested there yet.

Tried that, I still get freezes in the race loading screen and at the start of the race but it's much more manageable than what the DX11 renderer does and I can live with the lack of brightness / contrast control since the game isn't dark as hell like with the DX11 renderer, so I guess that solves my problem.

Thanks for the help.
Reply
#5
Did you try changing the CRC hack level? For me setting the CRC hack level to Full (Safest) fixes most of the glitches and freezes that are present in DX11 / Opengl hardware mode.

As for making the game brighter Shader config > Enable shader boost , saturation 60 , brightness 80 , contrast 47. You can play with the settings to match your preference.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#6
Experience same micro shuttering with GT4 only on OpenGL. Unchecked large frame buffer can minimise the issue but doesn't fully fix it.

At first, I'm thought it was my hardware issue but now I'm think pcsx2 OpenGL issue. Smile
Reply
#7
As said above, latest git + no large frame buffer. CRC ought to be partial.

Try to disable depth emulation in hw hack? Try to monitor the vram usage.
Reply
#8
(06-11-2016, 09:57 AM)gregory Wrote: As said above, latest git  + no large frame buffer. CRC ought to be partial.

Try to disable depth emulation in hw hack? Try to monitor the vram usage.

yeah full crc crash emu with error with not enough ram
Reply
#9
And did you try custom resolution ?
Reply
#10
(06-11-2016, 09:57 AM)gregory Wrote: As said above, latest git + no large frame buffer. CRC ought to be partial.

Try to disable depth emulation in hw hack? Try to monitor the vram usage.

I just tested that again and the game does indeed have a pretty big VRAM usage spike (above 2GB) on 3 spots, The loading screen, the blackscreen once you hit start a race and the fade-in at the end of the countdown, using any CRC hack level above partial just makes the spikes happen longer, using none or minimal doesn't seem to make any change compared to partial, the spikes do get much smaller over time (VRAM usage then goes to about 1600-2000MB once you go into a menu and at the very beginning of a race during the camera panning and the countdown then goes down to 900-1300MB once you get control of your vehicle), despite the VRAM spikes not happening anymore the stuttering is still very present

Disabling depth emulation doesn't seem to really make any change at all, none of the other hacks seem to have any impact on it either.

Custom resolution slightly reduce the stutter but it's still present

Checking Allow 8-bit textures or Large Framebuffer makes the stutter way worse.

The 1.4.0 plugin does have those spikes too but once they calm down the game hover around the same VRAM usage as the plugin from the latest GIT except it does not stutter at all.

EDIT: That only applies to the OGL renderer since I haven't tested the DX one at all.
Reply




Users browsing this thread: 1 Guest(s)