Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sudden halving of frame rate?
#1
I've been playing Kingdom Hearts 2 and the game was playing great, I get up to go to the toilet and when I return the frame rate is suddenly halved... I didn't press anything to trigger this and I see no option in the configuration screens to undo it.

Here's a copy of the Console window:

Code:
PCSX2 1.2.1.r5873 - compiled on Feb  3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
    Operating System =  Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
    Physical RAM     =  6134 MB
    CPU name         =  Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
    Vendor/Model     =  GenuineIntel (stepping 05)
    CPU speed        =  2.672 ghz (8 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 0098e3bd
    x86EFlags        =  28100000

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: L:\Emulators\Playstation 2\Plugins\gsdx32-sse4-r5875.dll
Windows 6.1.7601 (Service Pack 1 1.0)
    Binding  PAD: L:\Emulators\Playstation 2\Plugins\lilypad-r5875.dll
    Binding SPU2: L:\Emulators\Playstation 2\Plugins\spu2-x-r5875.dll
    Binding CDVD: L:\Emulators\Playstation 2\Plugins\cdvdGigaherz.dll
    Binding  USB: L:\Emulators\Playstation 2\Plugins\USBnull.dll
    Binding   FW: L:\Emulators\Playstation 2\Plugins\FWnull.dll
    Binding DEV9: L:\Emulators\Playstation 2\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 210ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'Primary Sound Driver' (Windows DirectSound)
*** Device 1: 'Speakers (Auzentech X-Fi Forte)' (Windows DirectSound)
*** Device 2: 'Speakers (Auzentech X-Fi Forte)' (Windows WASAPI)
*** Device 3: 'SPDIF Out (Auzen X-Fi SpdifOut [0001])' (Windows WDM-KS)
*** Device 4: 'Speakers (Auzen X-Fi Audio [0001])' (Windows WDM-KS)
    Opening CDVD
isoFile open ok: F:\Kingdom Hearts II (USA).iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1936768 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: C:\Users\Paul\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Paul\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.00(14/06/2004)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_210.05;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_210.05;1) Game CRC = 0xDA0535FD, EntryPoint = 0x0010001C
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_210.05;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
Overall 0 Widescreen hacks loaded
Loading patch 'DA0535FD.pnach' from archive 'L:\Emulators\Playstation 2\cheats_ws.zip'
comment: KH2 - NTSC-U
(Wide Screen Cheats DB) Patches Loaded: 17
(FrameLimiter) SlowMotion ENABLED.
Overall 0 Widescreen hacks loaded
Loading patch 'DA0535FD.pnach' from archive 'L:\Emulators\Playstation 2\cheats_ws.zip'
comment: KH2 - NTSC-U
(Wide Screen Cheats DB) Patches Loaded: 17
(UpdateVSyncRate) FPS Limit Changed : 29.96 fps

Edit: From the look of the title bar the "Limiter: Slowmo" option has become enabled and I have no clue how you disable it so I might just set slowmo and turbo both to 100% speed >.> so that it never bothers me again.
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply

Sponsored links

#2
Tab enables turbo mode,and shift+tab enabled slow motion
Reply
#3
Ooooh, okay would be nice to see that mentioned in the UI like how it says F4 to toggle the limiter off/on. Also I would like to note that setting slowmo to 100% speed didn't actually accomplish anything at all. It remained slow, does changing that require a restart of the emulator or what?

Thanks, I probably triggered it when trying to access Steam Overlay even though I'm not running the emulator via Steam >.>"
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply
#4
When you press tab or\and *****+tab,do you see in the console that the speed is set to something different

It the console above it says that the slowmontion is enabled and the speed set to 29.96(which is 50%)

Don't know if it's just here but Shift+Tab set slow motion only once.If you continue holding shift and just pressing tab,it will not switch between normal and slow motion but between normal and turbo.
Meaning if I want to switch between slowmo and normal,I have to release the keys after each mode change
Reply
#5
Nah that wasn't an issue I was encountering, but it is interesting to note so thanks. I changed what game speed Slowmo and Turbo modes operated at to 100% game speed but even in Slowmo it still ran at 50% speed. It wasn't until I restarted the emulator that Slowmo correctly operated at 100% game speed.
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply




Users browsing this thread: 1 Guest(s)