Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird slowdown running PSx2
#1
Hey guys I'm new here but i kind of have an idea of what im doing.

Yesterday i first started PCSX2 and it was working almost perfectly
I was playing FFX and the fps would only drop a bit during cutscenes.

Then today without changing any of my configurations i ran PCSX2 loaded upFFX and it would be at full speed for a while then after a couple minutes of playing the game would slow down to 20-30fps.

I have tried changing my graphics and sound configuration and the rest of them and it still does the same thing, plays fine for a while but then slows down after 2 or 3 minutes. I also tried all the speed hacks and it seems to take longer for it to slow down but it still does eventually.

Does anyone know why its doing this im thinking it may be the game, i doubt its my PC because as i said it was running fine all yesterday but ill
go ahead and leave my specs here anyway.

-Intel core 2 duo E7200 2.53 GHz cpu
-NVIDIA GeForce 9500 GT graphics card
Reply

Sponsored links

#2
Odd, the only times I have ever had a problem like that is when I use my laptop, and it gets unplugged, or when it runs really hot after playing for awhile. It ran fine yesterday? Did you play for an extended period of time?
Laptop
Intel Core 2 Duo PM8600 @ 2.4 GHz
4 GB DDR3 1066 RAM
ATI Mobility Radeon HD 3670 512 MB

Desktop
AMD Phenom II x2 550 (unlocked to 4)@ 3.5ghz
4 GB DDR3 1600 RAM
Sapphire 5770 1GB
Reply
#3
Yes yesterday it was running well for a while so yeah i was playing for a long time, but after 3 minutes of playing today it would slow down.

Also im curious as to what you mean when you said this happens when your
laptop gets unplugged.

One more question to anyone that can answer. do you think my PC is supposed to be able to handle this, i mean obviously it did
the previous day but does anyone here think that might have been some fluke?
Reply
#4
(03-02-2010, 07:50 AM)PCboardbum Wrote: Yes yesterday it was running well for a while so yeah i was playing for a long time, but after 3 minutes of playing today it would slow down.

Also im curious as to what you mean when you said this happens when your
laptop gets unplugged.

One more question to anyone that can answer. do you think my PC is supposed to be able to handle this, i mean obviously it did
the previous day but does anyone here think that might have been some fluke?

what he means is running on AC Power (charging ur laptop). And what OS are u running ?
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#5
disable any power saving thing in the power option in the control panel..
the problem hit me once..
after configured something my cpu clock running at always 100% ..
[Image: 871087.png]

*Mio sees a ghost for the first time*
Mio: Aaaaaaah!! x_x
Seriously, the way she acts, you'd think she grew up with ghosts.
Reply
#6
Okay so i went into power option in Control Panel but i couldn't find any power savings setting that was on or anything

you said you had this problem before and fixed it, so could you tell me what it is that you did exactly.

oh and im running windows XP by the way.
Reply
#7
Tell us all the settings you use in playing the game, or it is going end up wasting a page or two and everyone's time trying to guess what your problem is.
AMD Athlon II 245 @ 3.55ghz, 9600GT @730mhz 1115mhz, vista sp2 32bit
Reply
#8
Graphics- Using GSdx SSE2
resolution: windowed
Renderer: Direct 3D9 (Hardware)
Shader: Pixel shader 2.0
Interlacing: None
D3D internal res: 1024 by 1024
NLOOP hack: checked (gray)
Texture Filtering: checked
Alpha correction (FBA): checked

Sound- SPU2-X
Interpolation: Linear
Disable effects processing: checked
Module: Direct Sound (Nice)
Latency: 125ms
Disable time stretching: checked

Cdvdrom- Linuz Iso CDVD

cpu- all boxes checked and frame limiting set to limit at 60 fps

Speed hacks are all off but i have tried each of them and they don't correct the problem.

Everything else is pretty much all set to defalt also any check boxes I did not list are all uncheck and I left out stuff i
thought unimportant such as controller settings. If it turns out something I left out is important let me know.
Reply
#9
1. Try the latest beta and the latest plugin ( can be found in the sticky section).
2. Also, you don't really need to set frame limiting; using 0=default or auto is just fine.
3. Use X audio instead of direct sound in spu2-x.

Note that in latest beta, Idle loop fast-forward in speedhack section works very nice for FFX
AMD Athlon II 245 @ 3.55ghz, 9600GT @730mhz 1115mhz, vista sp2 32bit
Reply
#10
Quote:Shader: Pixel shader 2.0
Definitely bad, can cause low speeds and bugs, set it to PS 3.
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)