Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga ep 1 OpenGL HW problem
#1
hello everyone, i'm having problems running Xenosaga ep1 on openGL HW mode. i'm using pcsx2 git build v1.3.1-1588-g191453d compiled on december 28. the issue starts in the scene where shion says "good morning KOS-MOS". the emulator drops to 15fps but EE and GS values don't even rise above 30%. however, if i do run it in openGL software mode or d3d11, it runs at normal speed.

Computer specs:
Intel i-7 6700HQ
Windows 7 64bit
Nvidia gtx970m 3GB

PCSX2 specs:
git build v1.3.1-1588-g191453d
all stock settings

attached are screenshots comparing direct3d and opengl, notice the gs and ee values of the openGL

                           
Reply

Sponsored links

#2
Maybe this is some new bug(I don't try the game often)....Set "Blending Unit Accuracy" to None,anything else reduces the speed by a lot(there is no difference between basic and ultra)
Reply
#3
(12-31-2015, 07:45 AM)vsub Wrote: Maybe this is some new bug(I don't try the game often)....Set "Blending Unit Accuracy" to None,anything else reduces the speed by a lot(there is no difference between basic and ultra)
setting blending unit accuracy to none made it work a whole lot faster. with the frame limiter off, i'm hitting 80+fps and GS is hitting 100% now instead of being stuck at 15-20%. thanks! do i need to report this to the bugs section?
Reply
#4
Probably but I'm not sure if this is a new thing or it's know(at least by gregory)
Edit:It seems that this option in that game make the gpu core work at 100%...I get that high usage at that exact place while using None only if I use something like 7x scaling.
Reply
#5
Is the first level already slow?
Reply
#6
Yes,anything but None reduces the speed by a lot(there is no difference in the speed between basic and any other mode(except none))even while using Native

None - 180fps during the tutorial(picture 5/6)
Anything else 54fps(Ultra is with 1 or 1.5fps slower)
Reply
#7
(12-31-2015, 11:31 AM)vsub Wrote: Yes,anything but None reduces the speed by a lot(there is no difference in the speed between basic and any other mode(except none))even while using Native

None - 180fps during the tutorial(picture 5/6)
Anything else 54fps(Ultra is with 1 or 1.5fps slower)

Hum, if ultra is as slow as basic, it means all rendering commands are processing in accurate mode. It is bad for the performance. Normally basic only enable broken rendering and free commands (free from a CPU PoV). By the way is the rendering better/worst in basic mode, might worth to check without CRC hack?

Could you also check with/without accurate date?
Reply
#8
I guess I was looking at the percentage and said that's the fps Tongue2
But still it's a lot slower with anything other than None

Now for what you asked
There is no difference between Basic and any combination of those...Hardware Depth,Accurate Date,All CRC levels.Also either I don't see it or there is no difference in the quality between basic and ultra
Reply
#9
tried it both crc hack level none and accurate date off and the slowdown still persists when basic blending accuracy is active.
Reply
#10
Ok, now i'm confused. it seems that the issue isn't just in Xenosaga. i tried it with SO3 and the same thing happens. slowdown on the first cutscene on both OGL and D3D. in KH2, it slows down on D3D but runs normally on OGL. perhaps it's because of the skylake processor? i recall reading somewhere that there are issues with skylake and pcsx2


edit: now it's ok. wtf.

edit 2: yeah, i think it's the skylake processor. i ran pcsx2 with CPU-Z active and i see it jumping between 2.6 and 3.2GHz. (edit: added a post with CPU-Z on the slowdown) maybe someone can look at it.

   
Reply




Users browsing this thread: 1 Guest(s)