Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ZZogl: ERROR: Need GL_EXT_framebuffer_object for multiple render targets
#1
Code:
ZZogl: ERROR: Need GL_EXT_framebuffer_object for multiple render targets

That's what it prints in the console, and a window appears that says "your computer might have insufficient resources". I'm on Archlinux (I've tried both pcsx2 and pcsx2-bin, pcsx2-svn apparently doesn't contain binaries) and my graphics card is NVidia GeForce 7600 GT.

Any ideas how to fix this?
Reply

Sponsored links

#2
Check that your 32bits drivers is correctly installed. It probably better to use pcsx2-svn package, it will build the latest version.


Edit: there is also a special archilinux thread here:
http://forums.pcsx2.net/Thread-PCSX2-for-Archlinux
Reply
#3
Yep, I have the proprietary nvidia drivers installed from repos. And as I said, for some reason pcsx2-svn didn't build the binaries, just stuff in /usr/share and such. It's entirely possible I screwed up something, so I'll just try again. And I'll make sure to post in the Archlinux thread too.

Thanks for your reply!
Reply
#4
do you have a 64bits system ? Sometimes the 32bits part of the driver is not properly installed . I know that previous release got some buggy detection of extension on geforce 7 but it is fixed now. You can check extension with glxinfo command (or the nvidia specific tool)
Reply
#5
No, I don't have a 64bit system, and about glxinfo:
Code:
theon@delta:~$ glxinfo|grep -i frame
    GLX_EXT_texture_from_pixmap, GLX_EXT_framebuffer_sRGB,
    GL_ARB_framebuffer_object, GL_ARB_get_program_binary,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_blit,
    GL_EXT_framebuffer_multisample, GL_EXT_framebuffer_object,
    GL_NV_fragment_program2, GL_NV_framebuffer_multisample_coverage,
What does that mean?
Reply
#6
Which driver version do you have? and which version of pcsx2 exactly do you have. I will suggest to clean everythings and to retry with only the latest version.
Reply
#7
pcsx2-svn should for sure build the binaries of PCSX2. Can you build it locally/without yaourt (see how in the Archlinux thread) and post here the build log (add '-L' to 'makepkg') ?

And do you have latest version of nvidia-utils, 295-17 ?

Archlinux user and need help with PCSX2? Consider asking it in the Archlinux specific forum at http://forums.pcsx2.net/Thread-PCSX2-for-Archlinux Tongue
Reply
#8
@gregory:

I was able to reproduce this error. Looks like Sparsehash 2.0.1 has a different structure of header directory (See sparsehash NEWS) and cmake was not able to find it like it did before.
Here is my build log of pcsx2 and the content of the packages of (google-)sparsehash 1.12 and sparsehash 2.0.1 in archlinux.

Do you think you can solve this issue?

Thanks,

Rafael

Archlinux user and need help with PCSX2? Consider asking it in the Archlinux specific forum at http://forums.pcsx2.net/Thread-PCSX2-for-Archlinux Tongue
Reply
#9
See here: http://code.google.com/p/pcsx2/issues/detail?id=1222#c2
Reply
#10
Tried the patch, but it failed, with same build log.

Archlinux user and need help with PCSX2? Consider asking it in the Archlinux specific forum at http://forums.pcsx2.net/Thread-PCSX2-for-Archlinux Tongue
Reply




Users browsing this thread: 1 Guest(s)