Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"arbvp1 not supported." on Ubuntu 11.04
#1
After loading any game, I get the trace:

Code:
Interface is initializing.  Entering Pcsx2App::OnInit!
Applying operating system default language...
SetLanguage: 'English (U.S.)' [] is not supported by the operating system
Command line parsing...
Command line parsed!
(UserMode) Found portable install ini @ /home/x711li/.pcsx2-read-only/bin/portable.ini
ZZogl-PG: Calling GSinit.
ZZogl-PG: GSinit finished.
ZZogl-PG: Calling GSopen2.
ZZogl-PG: Capturing ZZOgl window.
ZZogl-PG:  Got Doublebuffered Visual!
ZZogl-PG:  glX-Version 1.4 with Indirect Rendering !!! It will be slow
ZZogl-PG:  glGetStringi opengl 3 interface not supported, fallback to opengl 2
ZZogl-PG:  arbvp1 not supported.

I have reinstalled `nvidia-cg-toolkit` to the newest version (3.1) so I don't know why this is occurring. I am currently using ZZ Ogl PG 0.3.0 (libzzogl-0.3.0) as the GS plugin.

Can anyone diagnose what's going on? Thanks in advance.

Sponsored links

#2
Also, the details of this problem are illustrated in this post as far as I know:

http://forums.pcsx2.net/Thread-ZZogl-Zer...#pid170329

Are there any recent commits/packages that will solve this problem?
#3
What! Your log is normal , i don't understand your title. can you explain it more clearly . There is a sticky thread with an unofficial build (that i will need to update by the way ), maybe you can try it.
#4
(03-19-2012, 12:35 AM)gregory Wrote: What! Your log is normal , i don't understand your title. can you explain it more clearly . There is a sticky thread with an unofficial build (that i will need to update by the way ), maybe you can try it.

The emulator crashes and that trace is all that is left. The process does not end, but it freezes so I must force quit after the trace is finished.
#5
I'm currently running on PCSX2 0.9.9.5133 if that helps.
#6
"ARB: Vertex Program 1.0 not supported" means either your hardware is not sufficient or you need a newer driver.

or that Arcum stuffed up the context level detection.
#7
Thanks Squall.

@x711Li, what is your GPU/drivers exactly? Try to look in the log directory there is probably a more verbose zzogl log file.
#8
lspci trace:
Code:
(lucid_i386)root@x711li-VPCF130FD:/home/x711li# lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 05)
00:1c.6 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 7 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (rev 01)
03:00.0 SD Host controller: Ricoh Co Ltd Device e822
03:00.1 System peripheral: Ricoh Co Ltd Device e230
03:00.3 FireWire (IEEE 1394): Ricoh Co Ltd Device e832
03:00.4 SD Host controller: Ricoh Co Ltd Device e822
04:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 4380 (rev 10)
05:00.0 USB Controller: NEC Corporation Device 0194 (rev 03)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

jockey-text trace (trying to automate driver update):
Code:
(lucid_i386)root@x711li-VPCF130FD:/home/x711li# sudo jockey-text
/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
Cannot connect to D-BUS
org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
#9
Are you using a 64 bits system?

Your GPU is not fast but it is recent. It must support at least opengl3 (I would say that arbvp1 is ogl 2...). Your driver is probably not installed correctly. Actually I'm stupid (face palm), the log file state that you haven't any opengl acceleration working:
Quote:ZZogl-PG: glX-Version 1.4 with Indirect Rendering !!! It will be slow
#10
Optimus configuration, im not even sure how linux handles optimus laptops, i've never seen one with linux in use.




Users browsing this thread: 1 Guest(s)