Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
custom resolution causes a strange screen stretching
#1
Hello my friends!

I had no idea how to search for this particular problem, so please forgive me if there had been other threads about similar problems.

I installed the latest version of pcsx2 and tried to start Silent Hill 2. Since I did not want to play it using the native resolution I chose 1920x1080 as custom resolution. Now everytime when I start the game - and even if I only chose 2x native resolution - the game's shown like this:

http://img5.fotos-hochladen.net/uploads/...e08t3r.png

I have absolutley no idea what causes this problem and how to fix it.

I use a / the "Europe v1.60 (04/10/2001)" BIOS if this is any necessary to know.

The strange thing is, the playstation 2 logo at the beginning and the console intro are perfectly fine. But just when the game starts, this unexpected horror begins.

Thank you in advance!
Reply

Sponsored links

#2
(08-23-2014, 11:55 PM)JohnSmith Wrote: Hello my friends!

I had no idea how to search for this particular problem, so please forgive me if there had been other threads about similar problems.

I installed the latest version of pcsx2 and tried to start Silent Hill 2. Since I did not want to play it using the native resolution I chose 1920x1080 as custom resolution. Now everytime when I start the game - and even if I only chose 2x native resolution - the game's shown like this:

http://img5.fotos-hochladen.net/uploads/...e08t3r.png

I have absolutley no idea what causes this problem and how to fix it.

I use a / the "Europe v1.60 (04/10/2001)" BIOS if this is any necessary to know.

The strange thing is, the playstation 2 logo at the beginning and the console intro are perfectly fine. But just when the game starts, this unexpected horror begins.

Thank you in advance!

Peculiar, it renders half-squashed-screen. What is your hardware? Are you using any speed/GSdx hacks? Have you changed clamping or rounding modes?
Reply
#3
I'm using and AMD 5770 and I do not use any speed hacks or what so ever. I also did not change many things. Here's a screenshot from my plugin-view:

[Image: unbenannte7lzbx9jgu.jpg]
Reply
#4
Does the glitch still occur in software rendering? (toggle with F9)
If not, is native resolution still exhibiting the problem?

By the way, your card supports DirectX 11, so switch to that instead, it's better most of the time.
Reply
#5
You are doing it wrong. At the Pluginresolution you chose for example 1024x1024 or 2048x2048, then in the emulationsetting you go to gs-window and set the resolution there
Reply
#6
(08-24-2014, 12:13 AM)Pikasora Wrote: You are doing it wrong. At the Pluginresolution you chose for example 1024x1024 or 2048x2048, then in the emulationsetting you go to gs-window and set the resolution there

No, what you said is wrong. The GSdx configuration controls the internal resolution the game is rendered at and the gs window settings control the size of the window GSdx will create.
[Image: newsig.jpg]
Reply
#7
Is widescreen hacks enabled? if so turn it off. it could be glitch in the game though
Reply
#8
(08-24-2014, 12:25 AM)Bositman Wrote: No, what you said is wrong. The GSdx configuration controls the internal resolution the game is rendered at and the gs window settings control the size of the window GSdx will create.

set internal resolution to x4 native and the windows will scale it down -> better graphics and no strechted bs
Reply
#9
(08-24-2014, 12:28 AM)Pikasora Wrote: set internal resolution to x4 native and the windows will scale it down -> better graphics and no strechted bs

You really have no idea what's going on here, better sit this one out mate.
Reply
#10
(08-24-2014, 12:13 AM)Coornio Wrote: Does the glitch still occur in software rendering? (toggle with F9)
If not, is native resolution still exhibiting the problem?

By the way, your card supports DirectX 11, so switch to that instead, it's better most of the time.

Switching to software rendering does not do anything, it just starts to flicker. It also does not matter whether I use DX11 or DX9.

tsunami2311 Wrote:Is widescreen hacks enabled? if so turn it off. it could be glitch in the game though

It is disabled.
Reply




Users browsing this thread: 1 Guest(s)