Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
dot hack G.U vol 1 no shadows bug
#1
Hi,

I've been trying for a while now to fix this to no avail. I'm using GSDX r4723, Directx 11 Hardware mode in PCSX2 0.9.8.
I'm aware of the fact that running GSDX in software mode fixes the shadows, but running it in software slows down the FPS too much.
So basically, the characters have no shadows, and instead there are black flickering lines on the ground coming from every character.

Is there any way to solve this? The game runs perfectly in every other way, and maybe that's why this bothers me something immense.

Thanks
Reply

Sponsored links

#2
It sounds like an emulation problem. That's why it only works completely in software mode. Hardware isn't finshed. Tongue
You can try downloading the latest SVN build http://buildbot.orphis.net/pcsx2/ (This is not release and may contain bugs/unstable but I've had no problems) to have a look and see if the shadows are now included in Hardware mode.
Good luck.
Reply
#3
Ah, checked it out, and sadly it doesn't seem to solve the problem, though I can now play through the first battle in software mode at 60 fps, so that's something. I'll check the town tomorrow. Meanwhile, if anyone else has any ideas how to fix the bug in hardware mode, please do tell. Although, if it is an emulation problem as Hellraiseradio said, I'm guessing the only solution is to wait for an update?
Reply
#4
I don't have the game to check myself, but you could probably kill the shadows completely using skipdraw if you prefer playing without them instead of with a glitch in their place, if you don't have such option in GSdx, add "allowHacks=1" to your GSdx.ini(or change 0 to 1 if it's already there, but disabledTongue). Having enabled hacks go to GSdx options and try typing 5 inside skipdraw box and if those shadows dissappear, decrease it to lowest value they are killed or increase to 10 or more if they are still visible with 5. For fixing it completely you'll probably need to wait alot as GSdx doesn't seem to have much rewrites(through I'm not a tester to know for sure if there aren't anyTongue).

Eventually check if other option doesn't break shadows in this game in hardware mode. Custom internal res at times can make such problems, soo make sure you're using a multiply of native and it's also worth to check native itself. Offset hack could have similar effect too at times, soo make sure it's not on, unless other things in this game needs it, but then playing in native would fix all of it. Also texture filtering at least in one game broke textures for me completely when applied fully(a check - which applies them for 3D and 2D surfaces) soo make sure it's grayed out(bluish in win vista/7) soo it does apply only at 3D surfaces(like in PS2) or you could try disabling it completely too just to check every possibilityTongue. As a hardcore check, DX9 hardware is also something worth a try. It's usually less compatible and slower, but there are few exceptions of the rule in which it can look better or even be faster.
Reply
#5
Thanks for the suggestions, but I've tried all of that already I'm afraid. Sad
Reply
#6
(09-24-2011, 01:21 PM)miseru99 Wrote: Having enabled hacks go to GSdx options and try typing 5 inside skipdraw box and if those shadows dissappear

Yep like miseru says, but not 5, u only need 1, i tested my self.
Reply




Users browsing this thread: 1 Guest(s)