Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
need help... weird fps stats
#1
ok, i wonder what's happening here...
i got a constant fps showing around 58-60fps.. but actually the game move so slowly... <only using 5-10% of cpu usage>
and when i press tab <change limit to none/normal> the fps showing 80++ <more than 10%cpu usage> and the game start to move normally, but the sound play so fast and its really annoying if we watch a cutscene like that.

and the question is, why do i get 58-60 fps when the game's run slowly and laggy...? then when i remove the fps limit, the speed's increasing... so, it's not my pc's fault... any idea to fix it?

sorry, my english's really bad. i hope u understand what i mean.
E7300 - HIS HD4670 - 2GB RAM

.Hack//GU vol 1-3 [beaten]
FFXII [beaten]
Ar Tonelico II [cloche's route beaten]
Grandia III - 1.5 hours
VP Silmeria - 5 minutes lol
Reply

Sponsored links

#2
Overuse of speed hacks causes that.
[Image: newsig.jpg]
Reply
#3
(02-06-2010, 12:02 AM)Bositman Wrote: Overuse of speed hacks causes that.

i don't use any speed hacks... using default cycle rate

oh yeah, playing grandia III with speedhacks on, it makes the game run slower...
E7300 - HIS HD4670 - 2GB RAM

.Hack//GU vol 1-3 [beaten]
FFXII [beaten]
Ar Tonelico II [cloche's route beaten]
Grandia III - 1.5 hours
VP Silmeria - 5 minutes lol
Reply
#4
Hm it's your idea then. If the game is running at 60 fps, that's full speed. If you run it at more than that, sound will get out of sync with the video since you're not running it at the normal speed (same if it's slower than 60)
[Image: newsig.jpg]
Reply
#5
no... here i give an example.
i'm playing grandia 3, when i first play the game, it runs normally a real 60fps. and then, when i walk on some place in the same city, it suddenly run slower/laggy <slow motion> - it seems that place is demanding more of cpu usage.. but the fps still showing 58-60fps... when i try to remove the fps limit, the fps shows 80fps++ and the game run like 'normal', except for the sound which still not sync with the video...
and then when i pass on that place, it suddenly turn to normal again...

in other words, even at the laggy time, it still shows high fps rate 58-60..

the same condition happened when i try to play VP silmeria...
at the first try, i got slow motion on 60fps... and then i restarted the pcsx2, using the save states, it only shows 14-20fps on the same place... <it runs as slow as the first try>

once again im sorry for my english... Tongue2

ah, sorry i forgot to mention...
im only using 3d geometry hacks <right corner>, i put it in the middle... it says 'experimental' -> could this be the problem?
the other hacks, i set them to default.
E7300 - HIS HD4670 - 2GB RAM

.Hack//GU vol 1-3 [beaten]
FFXII [beaten]
Ar Tonelico II [cloche's route beaten]
Grandia III - 1.5 hours
VP Silmeria - 5 minutes lol
Reply
#6
We'll need to see your settings.

Are version of pcsx2 are you using?
Reply
#7
So you are using speedhacks... if the EE cycle rate is on default then it's probably the "VU cycle stealing" one, but as Pandemikk mentioned it'd help if you posted your settings.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
The same thing happens to me.
To be more precise, the reason that made me join is exactly the same issue as his.

I am playing Persona 4.

My machine is Okay, except the Video Card:

Core 2 Duo E7400 @ 2.8GHz
3 GB DDR2 Ram
HD 2x 1TB Samsung Raid 0
ATI Radeon HD 3470
Windows 7 x86 - N Version
PCSX2 0.96 R1888

What happens?

Just like him, the FPS stay constant on the number, 58-62, since I put 62 as the FPS limit.
But when the camera gets in situations with a big draw distance, like in a corridor, the game gets slow, and in small places or no draw distance, or complicated graphics, it runs faster.
However the sound is always on time, and turning the FPS limit off makes it run smoother, but it will cause the sound to go to fast.

Config: My brother put it up, everything at max. So that would be basically the first stop:

[Image: Untitled4.png]

[Image: Untitled3.png]

[Image: Untitled2-1.png]

[Image: Untitled1-1.png]
Reply
#9
Please don't hijack threads Bill. Make your own if you want support.
Reply
#10
@bill kamp:
You didn't even read the thread... speedhacks cause that, turn them off and see if it still happens...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)