Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
secret agent clank NTSC-U sound problems
#1
I'll start with system specs. Windows 7 professional 64 bit, 12GB RAM, nvidia GT 620 graphics card, i7-3770 3.40 Ghz cpu. pcsx2 version is 1.3.1-530-g62beb3a.

Okay in short the problem i seem to be having is that sound effects seem to not always play. For example say i get spotted by a search light, sometimes the alarm will go off, other times I just hear the sound effect start to play then immediately cut off without finishing. The same thing happens with enemies shooting at me sometimes as well. Its random, but pretty frequent. I'm using the spu2-x sound plugin, latency is set to 90ms and currently xaudio2. The game hasn't shown any signs of lagging so far but i've only played through some of the first level.

Thoughts?

EDIT
Portaudio has the same problem, i can't try direct sound, pcsx2 refuses to start a game if i select that option. Synchronizing mode is currently set to timestretch. Setting it to async doesn't seem to make any difference. Interpolation is set to catmull.

I should probably mention that the music has zero issues, and sound effects during cut scenes have no problems as well. I also forgot to mention that i'm using direct3d11 hardware mode. Speed hacks are all disabled except for mtvu which is turned on. Game fixes are all turned off.

EDIT AGAIN
Tried dropping the latency to the lowest possible of 30ms, that seems to help somewhat but the problem still occurs frequently. Switching from a fast boot to a full boot doesn't help with the issue. I've also tried switching to the latest stable version of pcsx2, no difference.
Reply

Sponsored links

#2
Do you use non-default settings? Any speedhacks?
Reply
#3
I already answered the speed hacks question in my previous post, but i'll say it again anyway, no speed hacks are enabled except mtvu. As for non default settings, the only one I can think of is that clamping mode is set to chop zero/full. The full was set to fix problems on another game I think.
Reply
#4
(06-22-2015, 01:38 AM)rmcin329 Wrote: I already answered the speed hacks question in my previous post, but i'll say it again anyway, no speed hacks are enabled except mtvu. As for non default settings, the only one I can think of is that clamping mode is set to chop zero/full. The full was set to fix problems on another game I think.

Thank you for editing your post there.

Anyway, have you tried with MTVU off? doubly sure no Gamefixes are enabled? possibly try different clamping settings, I know it sound crazy but i've seen VU mess up's completely remove music/sound.

On which note it could be worth trying the superVU setting instead, to see if that helps.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
turning off mtvu and and turning clamping back to default make zero difference.

EDIT
SuperVU runs into the problem less often, but it still occurs fairly frequently.
Reply
#6
Interesting... can you try playing with the different rounding modes for the VU's in that case
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
going through all 4 clamping and rounding modes, with superVU enabled, there is no noticeable difference between them for the problem. I guess the best way to put it is, that on microVU the problem occurs approximately 50% of the time with sound effects, with superVU it occurs approximately 10% of the time. 10% might not sound like much, but sound effects are being played on a very frequent basis. Breaking a crate, get caught by an search light, get shot at, dogs barking at you(related to getting caught by the light), so even at "10%" its still frequent enough to be very irritating.
Reply
#8
Do you run the game via iso or disk? If disk try to use the iso and the other way around.
Additionally if iso: how fast is your hdd?
Reply
#9
iso, and i'm not sure how to check how fast my hdd is.
Reply
#10
Being that it's a standard PC, that's unlikely the problem.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)