Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BUG: DS4Windows and PCSX2
#1
Problem solved.

Looks like PCSX2 can use a DualShock 4 Controller connected via cable without the need for DualShock4Windows program. 
However, using DS4Windows with default settings along with PCSX2 (with default controller plug-in setting) is going to cause a bug which makes the emulator believe that L3 button is pressed all the time. 
This bug does not show up when using DualShock4 Controller via Bluetooth, with or without DS4 Windows.
This is related to Gran Turismo 4 as L3 button pressed in-game pauses the moving bottom text. It also bugged the hell out of Wolfenstein: Operation Resurrection as it continuously centered the view. I believe this is a good thing to know.
I do not know if R3 button is affected, nor if it happens on other operating systems.

I managed to set up PCSX2 in order to play Gran Turismo 4 without major problems(clampings to full/extra, changed resolution to Full HD, etc) .
I don't know if my disc was scratched or something, but the bottom informational "flowing" text is standing still. This is happens with race/championship descriptions and, what bugs me the most, with information about tuning parts and what each car custom setting does. 
I did not find a thread about this, maybe I do not know how to search for it.
I do not want to mess around with the settings to render the game unplayable , therefore I am asking here:
Has anybody else encountered this problem ? Is there a solution ?

Edit:
Hardware:
CPU: Intel Core i7-6700HQ @ 2.60 GHz non-turbo / 3.50 GHz in turbo.
RAM: 8GB DDR4.
GPU: nVidia Geforce GTX 960M , 4GB VRAM, using latest drivers.
Windows 10 Pro, 64 bit.

Using PCSX2 v1.5.0 dev-2244-g854246846.

Non-default setting I am currently using:

EE/IOP Clamping Mode: FULL.
VUs Clamping Mode: EXTRA + Preserve Sign (problem persists on Extra mode).
GS Window: Aspect Ration 16:9, Custom window Size 1904 x 1032, Wait for Vsync on refresh STANDARD.
Speedhacks: Enable speedhacks; mVU Flag Hack disabled, MTVU enabled.
Game Fixes: Manual, but using no game fix.

GSdx settings:
Adapter: NVIDIA Geforce GTX 960M.
Renderer: DirectX 11 (hardware).
Texture Filtering: Bilinear (forced).

Hardware Renderer Settings:
Allow 8-Bit Textures checked.
Large Framebuffer checked.
Custom internal resolution, 1920 x 1080.

Using external shader with unchanged External Shader Config (it was just one file where I got it from).

Now some real shady things are going on. Did couple B-Spec races (in Japan Championship). After finishing it, I saw that I do have flowing bottom informational text. It was very blurry while moving, but same happens with the menus (on the shader page it was mentioned the fact that menus will appear weirdly with it activated).

I have changed some Anti-Aliasing setting somewhere, now I can't find where, but I do remember that I selected MSAA x16 (problem was still there) [EDIT: Option was in HW Hacks, which were turned off, so no MSAA present. Makes my game lag and freeze even with x4].
I really want to know what the cause / solution might be, as it can definitely help others with GT4.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.

Your hardware specs - CPU, Graphics Card, Memory, Operating System.
The version of PCSX2 you are using.
Any non default settings you are using.

Thank You.
Reply
#3
well... i tried to recreate it. except using ogl render. i have no idea what went wrong on your end. i didn't bother trying gsdx extended hacks. i just ticked mtvu. that's about it. it should run outta the box. does it do that in native and all standard (with mtvu perhaps) and ogl too?
Reply
#4
Hum, I see that you have the EE/IOP clamping to full, this will crash the game when going into a race, did you try without it to see if it's related?
Reply
#5
Nope. It does not have that problem with the settings you told me about.
However, I believe this is very weird. It does it sometimes and I cannot find the trigger. I started to pay a lot of attention to it but somehow it works perfect. I will start messing around with the game to see what triggers the freeze.
Reply
#6
Can you post a screenshot of what you're seeing?
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#7
Just reading your settings, a few things jump out as me. The one that I think may fix the text scroll problem:

mVU Flag Hack: Highly recommend you leave this one on. Never causes problems for GT4, and considering this game requires Extra VU clamping for some UI parts to look right, it may be related.

And there are some others that I just have some general thoughts on:

Custom Internal Resolution: Avoid using this if at all possible. Use one of the multipliers. Generally custom resolutions run GS harder than the multiplier that gives an equivalent (or higher) resolution. In some games this can also cause some graphical oddities.

Texture Filtering: Probably best to leave this on the Bilinear (PS2) setting, but maybe I'm out of the loop and Forced looks better.

Automatic Game Fixes: Best practice is to keep these on. I don't think GT4 has any, but again I may be out of the loop.

Renderer: Consider using OpenGL and setting the Blending Unit to Basic. It really brightens up the game and makes it look much nicer.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#8
(01-12-2018, 11:12 PM)Atomic83 Wrote: Hum, I see that you have the EE/IOP clamping to full, this will crash the game when going into a race, did you try without it to see if it's related?

I chose those settings in order to make the "READY" or "FULL-THROTTLE" text go away when I start a race. 
However, I have to switch both clampings to normal when I do "Licence" races because it crashes some of them.

Otherwise, with the settings list I provided, the game works without any bothering problem at all. (Race replays are... ultra-fast, kind of funny to watch but I never do so I just ignored them).
Reply
#9
(01-12-2018, 11:12 PM)Atomic83 Wrote: Hum, I see that you have the EE/IOP clamping to full, this will crash the game when going into a race, did you try without it to see if it's related?

That's a requirement for proper UI function in this game and has never crashed it. At least, on the NTSC-U version. Maybe PAL or NTSC-J is a different story.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#10
https://i.imgur.com/uXDB6ZP.jpg

The big red box contains the text that sometimes is frozen/ that sometimes works. I have no idea how to call it, since I posted this thread it mysteriously started to work. Or maybe I pay more attention to it right now. I am still searching for the trigger.
Very odd, I remember perfectly that yesterday I started the game and the text was frozen so I started to google my problem under a lot of names but could not find anything about it.
Now, I start the game the same way with (or I think so) the same settings and it works relatively fine (kind of blurry when it actually moves).


The settings for GT4 are taken from a thread I visited two-three days ago.
Reply




Users browsing this thread: 1 Guest(s)