Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Killer7 [NTSC-U]
#1
# PCSX2 version: official v1.4.0 release and pcsx2-v1.5.0-dev-2448-gd09737dbb-windows-x86 build
# CPU options: EE/IOP defaults, VUs defaults (also tested EE/IOP clamping to Full and VUs clamping to Extra+Preserve sign)
# Plugins used: GSdx 20160105132032 (MSVC 19.00, SSE41) 1.0.0 [gsdx32-sse] (hardware D3D11 and OpenGL)
# Description:

Hardware rendering via both D3D11 and OpenGL makes it possible to shoot through walls. Software emulation fixes this issue.
Confirmed by multiple users with various PC setups. Also happens on NTSC-J version of the game.

Examples:

https://clips.twitch.tv/CarelessWanderingKleePanicVis

https://youtu.be/gQqSSpXGZKU
Reply

Sponsored links

#2
What does it look like in SW vs HW? Can you post screenshots?
Reply
#3
Sure, here are some screenshots of the same gameplay moments in SW, HW in native resolution and HW in 4x resolution.

The plugin used is GSdx 20160105132032 (MSVC 19.00, SSE41) 1.0.0 [gsdx32-sse].
PCSX2 1.4.0 build.


Attached Files Thumbnail(s)
                       
Reply
#4
The screenshots don't really reflect the issue, it sounds like something else.

Can you try disabling MTVU and the mVU Flag Speedhacks? If that doesn't work, can you change both VU0 and VU1 to SuperVU?
Reply
#5
I mean, the issue is that a player shoots through walls (locations' collisions seem to be broken) when hardware renderer is enabled. It's not possible to observe this issue by looking at static screenshots. You can observe the issue on the videos I linked in the first post in this thread.

I don't use any speedhacks (MTVU and the mVU) during Killer7 playtests.
Changing VU0 and VU1 to SuperVU doesn't help.
Reply




Users browsing this thread: 1 Guest(s)