Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't run most games.
#1
EDIT: When using the Linuz plug-in for launching games, the warriors works but has no voice sounds.

So, i have PS2 games from my childhood lying around, and decided to get an emulator to play them on so i can boost my graphics and make my childhood games look more beautiful than ever, but i've run into some issues. I've gone over many compatibility guides for these games and nothing works. Im still trying to RIP other games as i type this but the ones i have done are Harry Potter and the chamber of secrets, ratchet and clank, mortal kombat deception, spider man, spider man 2, THUG2 and the warriors, none of which are working, and i made sure they work, not only is there loads of videos of them running in 4k at 60fps, but on the compatibility check list thing, they are all listed as working perfectly, but none are working, the issues are as follows:

Harry Potter: The games screen is cut along the right side and bottom, regardless of the scailing, and then once it gets past the saving part once you boot the game, it black screens. It gives an error that says "assertion failed: Vpu/vif - invalid unpack"

Ratchet and Clank 1: Black screens at the first cut scene when you first start a new game.

Mortal Kombat Deception: Sits on the MK logo and never moves.

Spider man 1 and 2: Both black screen instantly, the games dont even boot.

THUG2: Boots to the screen that says "please insert a playstation 2 disc"

The Warriors: Instant black screen, no boot.

I have noticed i am getting a cdvd read error, but whilst looking for fixes for that, nothing worked, at all, still get the same error no matter what i try. What do i do?

NOTE: It can't be a PC issue, my old, ***** PC from 2004 ran MK Deception, The Warriors and Ratchet and clank 1,2 and 3, flawlessly in 1080p, with an amd xenon x245 or some ***** thing and an AMD Radeon r7000 series card with 512mb of vram.

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]

In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
And what is your pc now.
What's important with emulation is the single threaded performance of your cpu and if your new pc has a cpu that is way better than your old one but it's lacking in the STP,that will be the pronlem related to speed.

Also,which pcsx2 version are you using and are you using any non default settings
And also keep in mind that the newer pcsx2 version you are using,the more power it will require from your pc because bugs are fixed and more things are emilated correctly

And also,I don't think Ratchet and clank 1 will work "flawlessly in 1080p",on some old pc.That game can be quite demanding even on recent hardware
#4
i matching with your radeon card mine is HD7770 on my haswell rig if i not mistaken it can run most of my ps2 games including R&C and even rpcs3 games!!

but CPU we need full details about that amd xenon x245 i think it's no such as thing as that amd xenon x245 this could be a amd athlon
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
#5
Well it did run Ratchet and Clank flawlessly, and my PC specs are intel g4560, gtx1050ti, 16gb ddr4 ram. Will be upgrading to an i7 7700k in a few days but at the moment that is my current rig. I have tried using both the latest dev build and the lastest 1.4.0 build, both give the same results. Same results also occur on all default PCSXE 1.4.0 settings and the various settings i've seen others use.

Do i need to give the results for every game that is broken, or just 1?
#6
the emulog for R&C games would be a good idea
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#7
Well on g4560 it is possible to run at good\full speed but not on something from 2004.
And cdvd read error means that there is something wrong with the image(not dumped correctly or damaged)
What did you use to make the images and can you post the emulog as jesalvein requested(one game is fine)
#8
1.4.0 is deserted now get the auto-build instead
https://buildbot.orphis.net/pcsx2/
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
#9
Here is the emulog for ratchet and clank

Code:
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
    Operating System =  Microsoft Windows 10 Pro (build 16299), 64-bit
    Physical RAM     =  16347 MB
    CPU name         =  Intel(R) Pentium(R) CPU G4560 @ 3.50GHz
    Vendor/Model     =  GenuineIntel (stepping 09)
    CPU speed        =  3.503 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 4ffaebbf
    x86EFlags        =  2c100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: D:\Downloads\Emulator Games\PS2\PCSX2 1.4.0\Plugins\gsdx32-sse2.dll
Windows 10.0.16299
    Binding  PAD: D:\Downloads\Emulator Games\PS2\PCSX2 1.4.0\Plugins\lilypad.dll
    Binding SPU2: D:\Downloads\Emulator Games\PS2\PCSX2 1.4.0\Plugins\spu2-x.dll
    Binding CDVD: D:\Downloads\Emulator Games\PS2\PCSX2 1.4.0\Plugins\cdvdiso.dll
    Binding  USB: D:\Downloads\Emulator Games\PS2\PCSX2 1.4.0\Plugins\USBnull.dll
    Binding   FW: D:\Downloads\Emulator Games\PS2\PCSX2 1.4.0\Plugins\FWnull.dll
    Binding DEV9: D:\Downloads\Emulator Games\PS2\PCSX2 1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9693 games on record (loaded in 160ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 10.0.16299
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
Current Renderer: Direct3D11 (Hardware mode)
    Opening CDVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (997376 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0 [File]: C:\Users\razor\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\razor\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: Japan   v01.00(17/01/2000)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.17, ctm:393Mhz, cpuclk:295Mhz )

PlayStation 2 ======== Hard reset boot
ROMGEN=2000-0117, IOP info (CPUID=1f, CACH_CONFIG=ffffffff, 2MB, IOP mode)
<20000117-050310,ROMconf,:11232>
# Total accessable memory size: 32 MB (B:2:8:0)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Dec 10 1999 17:48:37
  CPUID=2e20, BoardID=0, ROMGEN=2000-0117, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_971.99;1) Game CRC = 0xCE4933D0, EntryPoint = 0x0012D728
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.99;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SCUS_971.99;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SCUS_971.99;1
0 00100080 0013d2e0 ....................
Loaded, cdrom0:¥SCUS_971.99;1
start address 0x12d728
gp address 00000000
# Loader 'cdrom0:¥SCUS_971.99;1':pc=0012d728
Get Reboot Request From EE

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadbuffer: addrres 53300 args 0 arg
loadbuffer: id 25, ret 0
loadbuffer: addrres 55d00 args 0 arg
loadbuffer: id 26, ret 2
loadbuffer: addrres 55d00 args 0 arg
loadbuffer: id 27, ret 2
loadbuffer: addrres 5b200 args 0 arg
loadbuffer: id 28, ret 0
loadbuffer: addrres 5b200 args 0 arg
loadbuffer: id 29, ret 0
loadbuffer: addrres 5b200 args 0 arg
loadbuffer: id 30, ret 0
loadbuffer: addrres 5b200 args 0 arg
loadbuffer: id 31, ret 0
loadbuffer: addrres 65e00 args 0 arg
loadbuffer: id 32, ret 0
loadbuffer: addrres 99f00 args 0 arg

==========================================================
989snd (c)2000, 2001 Sony Computer Entertainment America
by Buzz Burrowes                               v2.9.5
                        (built Sep  6 2002 at 16:08:07)
                                         (pre-release 3)

NO MIDI VERSION! No MIDI, AME, or basic VAG sounds
                  (banks and streams only)

(build with sce library rev 2.5.4)
==========================================================
    Thread Priorities:
                         Sound Tick = 9
                           Main RPC = 58
                        Loading RPC = 59
                          Streaming = 60, 61, 62, 63
==========================================================

loadbuffer: id 33, ret 0
loadbuffer: addrres 65e00 args 0 arg
loadbuffer: id 34, ret 0
RPC Initialize
IOP_stashmgr: set rpc queue
IOP free mem: 509184
IOP_stashmgr: register function
IOP free mem: 189696
Suspending single plugin: GS
    Saving GS
    Closing GS
Recovering single plugin: GS
    Opening GS
Current Renderer: Direct3D11 (Software mode)
    Loading GS
Trap exception at 0x0020b930
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
* SPU2-X: Waiting for DSound thread to finish... Done.
    Closing PAD
    Closing GS
Plugins closed successfully.
#10
do you have another PS2 console ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)