Echoing sound in FFX-2 FMV and "ghosting" effect in hack//GU
The game itself runs at 60fps when set to 1440x1080, DX11 hardware mode but the FMV drops to 50fps (though I assume this is a fixed framerate anyway) and has flickering, echoing sound. For example, when Rikku says "Y, R, P, in position" (or something similar) it usually comes out as "Y, R-R, P, in-in position". I'm switching to software mode to fix the FMV gridlines problem with the game, but leaving it in hardware mode doesn't change the glitchy sound. I'm using PCSX2, and it works fine with the other game I've played on it, Xenosaga. All emulator settings are default, I've changed the speedhacks setting around as well as the sound settings, from worst quality to highest. Plugin settings can be seen in the attachment. The game is ripped onto my HDD as an ISO. My PC details are as follows:

Phenom II X4 955 BE 3.2GHz
4GB Corsair DDR3 RAM
ATI HD 58XX 1GB (I always forget the last two digits, I think it's around 70, though).

Finally (I just edited this in rather than making two separate posts), I briefly tried to play hack//GU and while it worked perfectly from a performance point of view, everything (structures and people alike) has a strange ghosting effect around it. I'm assuming it's the way the emulator deals with that sort of blurry effect the PS2 did in place of proper anti-aliasing, as also seen Atlus games such as Digital Devil Saga 1&2 and SMT: Notcturne. The problem is, on the PS2 it was a slight blur, on my PC it's like I'm seeing double - the ghost image is about a centimetre or two away from the thing it's a ghost of. Ah, talking of DDS, I guess I should also mention that I also briefly tried that out and, like hack//GU, it performed fine but had the single odd glitch that peoples' shadows were always on the "top layer"; that is, if you stand behind some NPCs, your shadow is on top of them. Any way to solve these two glitches would be greatly appreciated, as well as help with the main FFX-2 FMV problem.

Attached Files Thumbnail(s)

Sponsored links

"Ghosting" most of the time is an upscale bug, it shouldn't be visible in native res, it can also be fixed by offset hack(althrough sometimes this messes up something else) in GSdx options, if you cannot see an offsethack there, edit your GSdx.ini and change 0 to 1 in "allowHacks=" or if you don't have this line, add "allowHacks=1" in the end.
FFX-2 FMV's are pretty demanding in compare to rest of the game, unless you can get full speed in them expect it'll be stretched. It doesn't have much FMV's soo you can just minimize pcsx2 and watch it on youtube or something;P.
Thanks, but I don't seem to have a GSdx.ini file anywhere. There's just one file in the Inis directory, and that's for the SPU plug-in. I tried making one up and just adding in the line "allowHacks=1" but it didn't work.

Edit Found it hidden away in the My Documents folder. I hate it when things save there rather than to their own directory, but at least I've found it now.
Quote:Edit Found it hidden away in the My Documents folder. I hate it when things save there rather than to their own directory, but at least I've found it now.

Then use the binary version of PCSX2 that defaults saving all settings/inis in the folder you extract it to.
[Image: newsig.jpg]
Well the offset hack didn't make any difference, unfortunately. I set it to native res, then double and triple and found that the ghosting effect got worse as I went up, but wasn't too bad in triple, so left it at that. However, I've noticed another problem which is that the mini-map is broken up into little squares (see pic). Any idea what's causing that?

[Image: 792026148642649.jpg]
Offset hack works only in multiply of native in case you had custom res previously. Anyway the games were designed for one hardcoded resolution and soo upscale will always cause some problems, map divided on small squares is an example of such.

Users browsing this thread: 1 Guest(s)