Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX Slow downs: I am sorry. Please help.
#21
(06-10-2014, 07:37 PM)willkuer Wrote: What is the cpu usage in taskmanager during idling (windows)? How dows it change during emulation? Please keep an eye on the single core usage not the total usage.

Make sure MTVU is enabled. If I see it correctly the sliders are at minimum in saiki's settiings. You can try to increase them one-by-one. VU cycle stealing fakes better fps-readings. I would probably use EE cycle rate first. I think this fast cdvd is not needed. I at least never used it.

Use Async-mix in audio output settings of spux-2 instead of Timestretch to reduce the annoying music during slowdowns.

Have you tested if your cpu is really running at the given clock-rate? Maybe after upgrading the settings in the bios are not optimal anymore. I would check that with cpu-z.

You can probably enhance the quality by increasing the native resolution in gsdx plugin settings without decreasing the performance too much. This is mainly gpu-intense and you are cpu-limited. use the highest SSE-number that is available as gsdx-plugin. Use DX10/11 as hardware renderer.



If all of that doesn't work try superVU instead of microVU in the VU-settings in the emulator settings.

During Idle, CPU usage is 0-1% . During emulation, one core maxed out about 80% during the slow down. couple others were running between 28% and 64% during the slow downs.

I had audio sync mode set to none(audio can skip) because I thought that might have some affect on the slow downs (though I now suspect it doesn't work like that), but I just changed it to async as per your recommendation. The music is slowing down frequently with this setting, more so than before.

I haven't changed anything in the bios other than selecting the DVD-ROM drive as first boot device. No overclocking done. Brand new motherboard, cpu, gpu, ram, power supply, case, etc. even though they are older technology. CPU is running at 3214 MHz according to AIDA64 Engineer edition.

Changing the native resolution even to lowest setting (checkbox for native) doesn't fix the slow down which makes sense after you explained it. It does greatly improve the quality though if I select 2x or 3x as expected. I am using the hardware dx10.

I haven't a clue which SSE number I should be using because the links in the setup guide on this website do not list my CPU. Or rather, I can't tell which one is mine. I have a AMD Phenom™ II X6 1090T Processor. The architecture names elude me. If I find out which one is mine, how would I go about changing that setting? That option seems to have disappeared from the configuration menu.

MTVU is and was enabled. Checked again to make sure. I had EE cycle rate set at 2 and VU cycle rate at 0.

Good News:
After bumping those two one at a time, I settled on EE C.R. of 3 and VU C.R. of 2 and even though there is a black screen that lasts a few seconds in between scenes and the animation appears to be in slight slow motion, it is still a lot better than it was (both audio and video). Lip-syncing is wack, but that doesn't bother me. Frames Per Second were dipping into mid 20's mid 30's often, but now they rarely hit mid 40s and mostly stay around the high 50s low 60s. I didn't try using superVU instead of microVUIt, since I came to an acceptable frame rate without doing that. It really is like night and day even though there is still a slight annoyance (slow animations). I can live with that slight annoyance since I am now able to play one of my favorite games again thanks to you and the others.

Thank you so much for taking the time to help me out with this, willkuer. I am very grateful for your hard work and generosity with your knowledge and experience. I wish you the best things in life.

Cheers!
Reply

Sponsored links

#22
well there was still more that one can test. But if it is sufficient for you. If there is interest to enhance we can still continue.

Never read something like:
Quote:I wish you the best things in life.
Especially regarding that I didn't help you as much as I would like to.
Nevertheless I thank you and wish you the best as well. Hope you will also re-enjoy other games.
Reply
#23
(06-10-2014, 09:58 PM)Ham08 Wrote: During Idle, CPU usage is 0-1% . During emulation, one core maxed out about 80% during the slow down. couple others were running between 28% and 64% during the slow downs.
that's quite high for FFX. I wonder what we're missing here...
Quote:Changing the native resolution even to lowest setting (checkbox for native) doesn't fix the slow down which makes sense after you explained it. It does greatly improve the quality though if I select 2x or 3x as expected. I am using the hardware dx10.
ok. This confirms your GPU isn't the problem here.
Quote:I haven't a clue which SSE number I should be using because the links in the setup guide on this website do not list my CPU. Or rather, I can't tell which one is mine. I have a AMD Phenom™ II X6 1090T Processor. The architecture names elude me. If I find out which one is mine, how would I go about changing that setting? That option seems to have disappeared from the configuration menu.
Phonom II architecture will be let you use up to SSE2.
Good News:
After bumping those two one at a time, I settled on EE C.R. of 3 and VU C.R. of 2 and even though there is a black screen that lasts a few seconds in between scenes and the animation appears to be in slight slow motion, it is still a lot better than it was (both audio and video). Lip-syncing is wack, but that doesn't bother me. Frames Per Second were dipping into mid 20's mid 30's often, but now they rarely hit mid 40s and mostly stay around the high 50s low 60s. I didn't try using superVU instead of microVUIt, since I came to an acceptable frame rate without doing that. It really is like night and day even though there is still a slight annoyance (slow animations). I can live with that slight annoyance since I am now able to play one of my favorite games again thanks to you and the others.

Thank you so much for taking the time to help me out with this
[/quote]
Glad you finally got a somewhat "playable" situation. Still, you shouldn't even need speedhacks with that CPU when playing FFX.

I wonder why and it bugs me. Sad
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)