Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FireShock - native USB Windows Driver for Sony DualShock Controllers
(06-04-2018, 06:03 PM)Nefarius Wrote: Sorry for the long silence; I'm currently very busy with major changes I'll publish this month.

Well, it's been a month.

I fully understand that you're a busy person with a life outside of this, I just feel its a bit unfortunate that there hasn't been an update in a while.

Sponsored links

No offense, but can I get some help on wiping FireShock from my system? My Dualshock 3 isn't even being recognised by my PC anymore since I tried it out, the drivers have ganked my gamepad.


I managed it after thinking for a hot minute.

Find the Devices and Printers window, you can find the Dual Shock 3 there. Double-click it.
It'll open up a small "Dual Shock 3 Properties" Window. Click the Hardware Tab, and the button that says "Properties" in that tab.
Then it'll open up ANOTHER Properties window. Then click the "Change Settings button."
It'll open up ANOTHER Properties window, identical to the last. Finally, in this new window, there should be a Driver tab. There's a big ol' Uninstall button.
Hey, uh, I guess this is where you go to get help with Fireshock? Might not even be a Fireshock issue, but Windows tells me I have a driver issue with my DS3 controller.

It's that annoying "This device can't start(Code 10) STATUS_DEVICE_POWER_FAILURE", tried re-installing the drivers and rebooting a few times no go. Win 10 issue?

Anyway, I hope someone can chime in if they know a solution for this annoyance.


Users browsing this thread: 1 Guest(s)