Poll: Was this useful to you?
You do not have permission to vote in this poll.
Yes
29.17%
7 29.17%
Yes
16.67%
4 16.67%
No
54.17%
13 54.17%
Total 24 vote(s) 100%
* You voted for this item. [Show Results]

Thread Rating:
  • 7 Vote(s) - 3.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
For everyone with issues starting PCSX2 Mac
#41
(07-30-2012, 09:47 PM)awesome613 Wrote: Hi. My PCSX2 was working fine up till today. Now, I get the following code between booting an ISO and loading a save state (at which point the app crashes):
Code:
ZZogl-PG: Calling GSinit.
ZZogl-PG: GSinit finished.
ZZogl-PG: Calling GSopen.
ZZogl-PG: Creating ZZOgl window.
ZZogl-PG:  Got Doublebuffered Visual!
ZZogl-PG:  glX-Version 1.4
Xlib:  extension "XFree86-VidModeExtension" missing on display "/tmp/launch-Ol0m8K/org.macosforge.xquartz:0".
ZZogl-PG:  Depth 24
ZZogl-PG:  You have Direct Rendering!
ZZogl-PG:  Using multitexturing.
ZZogl-PG:  Maximum texture size is 8192 for Tex_2d and 8192 for Tex_NV.
ZZogl-PG: Disabling MRT depth writing.
ZZogl-PG: Initialization successful.
ZZogl-PG: Disabling MRT depth writing.
ZeroSPU2: Initialized portaudio...
ZeroSPU2: Created sound stream successfully...
ZeroSPU2: Started sound stream successfully...
ZZogl-PG: Disabling MRT depth writing.
ZZogl-PG: Current game CRC is bb3d833a.
Segmentation fault: 11
logout

[Process completed]

The same thing also happens whenever I start a game without save states. I tried re-downloading all of the plugins, but to no avail. Any ideas?

Also, this pops up occasionally:
pcsx2: Fatal IO error 35 (Resource temporarily unavailable) on X server /tmp/launch-Ol0m8K/org.macosforge.xquartz:0

If it's relevant, I'm using the 0.9.7 build released earlier this month.

Sorry, but I dont use Lion and NEVER used save states (I dont find them stable enough, only on PC then I make 5 (10, with backups) states everytime I save with states.)
And I have yet to see a solution for the segmentationo fault, sorry :-(
"Eventually you too will hear it, The Last Melody"
Reply

Sponsored links

#42
(08-02-2012, 11:55 PM)Kaze Wrote: Sorry, but I dont use Lion and NEVER used save states (I dont find them stable enough, only on PC then I make 5 (10, with backups) states everytime I save with states.)
And I have yet to see a solution for the segmentationo fault, sorry :-(

This happens every time I so much as start a game, either loading a save state, starting a new game, or loading a save file from the virtual memory card. Thanks for the help, anyways.
Reply
#43
(08-01-2012, 02:47 PM)hadept Wrote: It just jumps a bit in the dock. No windows appear. I keep running a full system search of x11.app and it's no where to be found. Only xquartz.app can be found.

I am afraid this is out of my league then. I always used X11.app.

You might want to try to do this in Terminal thou... I make no guarantees about results ^_^"

As I have absolutely NO IDEA as to what wineskin wrappers does to your computer(I have it myself, but never got it working properly, so I gave it up) I am afraid there is little more I can do for you than asking you to try again in Terminal, but why do you not have X11.app? It is supposed to be preinstalled on your mac....
"Eventually you too will hear it, The Last Melody"
Reply
#44
(08-02-2012, 11:59 PM)awesome613 Wrote: This happens every time I so much as start a game, either loading a save state, starting a new game, or loading a save file from the virtual memory card. Thanks for the help, anyways.

Well, as I said, the segmentation fault still is missing a public solution (probably a dev one too ^_^), the only thing I can tell you to try is reinstall everything (except Memory Cards and bioses ^_^)
"Eventually you too will hear it, The Last Melody"
Reply
#45
(08-03-2012, 08:51 PM)Kaze Wrote: Well, as I said, the segmentation fault still is missing a public solution (probably a dev one too ^_^), the only thing I can tell you to try is reinstall everything (except Memory Cards and bioses ^_^)

Nothing. D: I think it's a problem with my X11/XQuartz package - something isn't loading from the online server. Unfortunately, I cannot find a solution. So much for replaying various FF and KH titles. Sad
Reply
#46
(08-07-2012, 08:33 PM)awesome613 Wrote: Nothing. D: I think it's a problem with my X11/XQuartz package - something isn't loading from the online server. Unfortunately, I cannot find a solution. So much for replaying various FF and KH titles. Sad

Sorry I couldn't provide more help :-(
"Eventually you too will hear it, The Last Melody"
Reply
#47
dyld: Library not loaded: /usr/local/pcsx2/lib/libwx_baseu-2.8.0.dylib
Referenced from: /Applications/pcsx2.app/Contents/Resources/pcsx2/./pcsx2
Reason: image not found
Trace/BPT trap: 5
logout

[Process completed]




I keep getting this when I open the latest version for lion (Alpha 0.9.7)
Installed everything including nvidia frameworks.
Followed the guides.

nothing.

so what do think?
Reply
#48
(08-11-2012, 01:07 AM)tealfeathers900 Wrote: dyld: Library not loaded: /usr/local/pcsx2/lib/libwx_baseu-2.8.0.dylib
Referenced from: /Applications/pcsx2.app/Contents/Resources/pcsx2/./pcsx2
Reason: image not found
Trace/BPT trap: 5
logout

[Process completed]




I keep getting this when I open the latest version for lion (Alpha 0.9.7)
Installed everything including nvidia frameworks.
Followed the guides.

nothing.

so what do think?

EDIT2:
You are definitively missing something or PCSX2 can't acess the right resources, DId you also install PortAudio and Xquartz?

EDIT3:
Found this elsewhere:
Quote:EDIT 3: Is a XCODE 4.1 issue that has to do with llvm compiler and the "optimization" it does when there is need to build with native extension. The solution is to install a compatible Xcode, more info can be found at the RVM site.

EDIT4:
As I found nothing useful on the RVM site, I am gonna look around after a compiler, found this too:
Quote:the problem is MAC OS X lion related, is a XCODE 4.1 issue that has to do with llvm compiler and the "optimization" it does when there is need to build with native extension. The solution is to downgrade to snow leopard while lion and xcode get fixed

EDIT5:
I found something that looks like an actual solution:
Quote:It is unfortunate that we have to declare OS X’s default compiler as being broken. We do not recommend its use. Instead, we recommend people to use /usr/bin/gcc-4.2 (which is the non-LLVM GCC compiler) instead of /usr/bin/gcc (which is a symlink to /usr/bin/llvm-gcc). You can enable this on most build systems by setting these two environment variables:
Code:
export CC=gcc-4.2
export CXX=g++-4.2
Please tell me if this works ^_^
"Eventually you too will hear it, The Last Melody"
Reply
#49
Bumped (in case the question asker didnt get all the 5 edits ^_^)
"Eventually you too will hear it, The Last Melody"
Reply
#50
(08-13-2012, 04:33 PM)Kaze Wrote: Bumped (in case the question asker didnt get all the 5 edits ^_^)

Thanks for the help and

I am a little slow to those edits...

where do I set the environment variables or enter those codes?
Reply




Users browsing this thread: 1 Guest(s)