Gamepad not responding
I'm trying to setup Logitech Dual Action gamepad with Pcsx2. Both Lilypad and SSSPSX recognize the gamepad and all the buttons respond on the testing. However when I run a game I get no respond from any button when using Lilypad, and with SSSPSX the only respond I get is from the left analog stick X axis(With left, upper-left and lower-left all go upper-left; and right, upper-right and lower-right all going lower-right).

I tried testing it on both Pcsx2 0.9.6 and 1329 Beta with Lilypad svn 0.10.0, Lilypad 0.9.9 and SSSPSX Pressure Mod 1.7.0 plugins.
I have the latest driver for the gamepad.
I tested on Final Fantasy X and Metal Gear Solid 3 - both games working fine on all other aspects and with keyboard.

Any help would be kindly appreciated since some game mechanics are hard to do with a keyboard

Sponsored links

Did you by any chance see if your mappings actually save? If not,run pcsx2.exe as administrator by right clicking it and move it to a folder where you have write permissions (like my documents)
[Image: newsig.jpg]
You mean if anytime I restart Pcsx2 then my button configuration remain? Yes they do.
Hm this is strange...when you map buttons/axis with Lilypad,do the different buttons/axis get registered? Also try the test device feature of the plugin,see if any value there constantly changes without you pressing anything on the pad
[Image: newsig.jpg]
I have the same pad and I had the same problem a couple of weeks ago but I don't remember exactly how I fix the problem Sad

Try backup all of your settings and delete them all and configure everything again.
The buttons get registerd with the ones I'm pressing accordinly, the values don't change when I test them when nothing is pressed, and I've deleted the .ini files and reconfigured when I switched between Pcsx 0.9.6 and the Beta and it didn't help.

I've attached my Lilypad config screen, maybe there's something wrong there.
Pad 1 is my Keyboard mapping and Pad 2 is the Gamepad.

Attached Files Thumbnail(s)
Far fetched suggestion but are both First/Second Controller plugins set to lilypad in "config > configure"?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
I've tried all the available combinations for the controllers.
I remind you that I do get a response when using SSSPSX plugin, so maybe something is not configured right, or Logitech Dual Action is not supported?
my HCL ORIGNAL JOYPAD/GAMEPAD (with 2 joysticks) works fine...Tongue
INTEL CORE 2QUAD 9650 @ 3Ghz,
6 Gb Ram @ 1333 Mhz,
Display @ ATI RADEON HD 3450 @ 512mb
(06-29-2009, 07:55 AM)ferrariii Wrote: my HCL ORIGNAL JOYPAD/GAMEPAD (with 2 joysticks) works fine...Tongue

And how exactly this help?
Broshi what are your pcsx2 configurations,what plugins are you using(all of them)and also are you using speed hacks or something different that the default in Advanced

I'm sure that the problem was one of those:
1.Some option of some of the plugins is the cause of this.
2.Some plugin don't get along with LilyPad.
3.The revision(pcsx2 and plugins)that you're using is the problem.

(06-29-2009, 02:57 AM)Broshi Wrote: ...or Logitech Dual Action is not supported?

It is supported,like I said above I have the same pad and it's working fine here(I also had this problem several weeks ago but I somehow I fix it...sadly I don't remember how)

Users browsing this thread: 1 Guest(s)