Games take 2 minutes to start on new version
I hadn't updated since about June this year, so when I started PCSX2 today I updated to the latest version. Now when I start a game it takes about 2 minutes before the game will begin. Though once it starts there are no speed issues. So I went back to 1.6 and the games start normally.

I have a similar problem when starting Steam and also the Wii U emulator Cemu.  If anyone can tell me what's wrong with my system that makes it do this, I'd really appreciate it. I'm on Windows 10, with a Ryzen 5600 and an RX 6600. 

I'm sure it's something to do with C, but I've reinstalled all environments and nothing changes.

Sponsored links

Have you encountered any other problems with the updated PCSX2 emulator? And can you maybe describe this two minute process a bit more (for example, what the system console / program log writes down in the meantime)?
There aren't any other issues. Something has changed in the update that I think is now using a system call that it didn't use before. When the system gets that call it appears to go in a loop, then finally starts. The computer doesn't freeze in any other sense. The 2 minute between clicking and running also happens in Steam and Cemu.
I just tried an original disc game rather than an ISO and that started instantly. I've no idea what this means, but it means something.
either your HDD is dying or it's powering down and taking ages to start up (which could also mean it's dying).

If you have another drive, try putting it on that.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
It's not a hard drive error as I've tried ISOs from different drives. It's only these three programs that there's an issue with.

Cemu games start correctly when Cemu has loaded, but Cemu takes that same 2 minutes between clicking and it starting as exists between clicking on a game in the PCSx2 list and it starting.
ok, here's another thing - this 2 minute delay only happens after picking the first game. If I tell pcsx2 to then load another iso, it loads instantly.

I was thinking it might be something like a virtual drive issue. I've disabled "virtual clonedrive", but that's not had an effect.
What happens if you just run the bios(no game)
It could be video drivers
Have you tried the "fix all" solution of restarting the pc which often helps for whatever reason Laugh
Did you tried using other renderers(DX\OGL\Vulkan and Software mode)
Booting just the bios takes the same 2 minutes.

I just installed the latest drivers a few weeks ago for the rx 6600, but that didn't change this delayed start for Steam or Cemu.

I just tried the various renderers and it's all the same.

I get the feeling there's some kind of looping error which takes the computer a couple of minutes to get stuck in and then auto release.
ok, another update - it's 2 minutes from when the emulator loads that is relevant. Not two minutes from starting to load anything. If I load the emulator and leave it for two minutes then everything's fine. This didn't happen in 1.6, it does happen in 1.7. Is it the code used for the new layout that's the issue? I'm determined to narrow this down as it can't just be me that has this problem.

Users browsing this thread: 1 Guest(s)