Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is my laptop good enough for Persona 4?
#1
Hi, i've been wanting to play P4 for a while. So i got it on the emulator but the game is mostly slow. it play fine at first then at goes down a lot.

My processor is i7-7700HQ 2.80G GTX 1050ti
Reply

Sponsored links

#2
It is fine but it is possible that pcsx2 is actually using your intel card rather than your nvidia card.
Did you tried right click on pcsx2 and choose the nvidia card?

Also what are your pcsx2\gsdx settings(I hope it's not some crazy 8x scaling and 16x msaa)

I am on 6700HQ(little slower than your cpu) and with gtx 1060 and the game works fine
And are you playing from the disk or image

Edit: Or maybe your are ruuning some power saving mode
Reply
#3
if it is playing fine then the performance drops I would recommend getting a program like MSI Afterburner or any other program to track in real time your temperatures and clock speeds. My guess is either your laptop is hitting a power limit or temp limit and throttling which is killing performance. This would be the first thing to test for.
Reply
#4
(06-07-2018, 05:07 PM)vsub Wrote: It is fine but it is possible that pcsx2 is actually using your intel card rather than your nvidia card.
Did you tried right click on pcsx2 and choose the nvidia card?

Also what are your pcsx2\gsdx settings(I hope it's not some crazy 8x scaling and 16x msaa)

I am on 6700HQ(little slower than your cpu) and with gtx 1060 and the game works fine
And are you playing from the disk or image

Edit: Or maybe your are ruuning some power saving mode

i tried using the card after what you told me and it raised above 100% for me. However, it's still the same result it slow down (especially at the fog area at the start of the game)

Yeah i was using 8x scaling and 16x msaa. 

My laptop is not on power saving.
Reply
#5
Your gpu is not that powerful for something like that.
Lower the scalling,disable msaa and use OpenGL if you are not.

Also,if you are using your laptop monitor,you will definetly not notice any graphical improvements above 3 or 4x scaling
Reply
#6
(06-07-2018, 05:20 PM)vsub Wrote: Your gpu is not that powerful for something like that.
Lower the scalling,disable msaa and use OpenGL if you are not.

Also,if you are using your laptop monitor,you will definetly not notice any graphical improvements above 3 or 4x scaling

[Image: 0CGyGme]

These are my setting. It runs at 50% with them.
Reply
#7
That's just GSdx
Did you change anything in HW hacks,what are your pcsx2 settings(if you are using preset 2,there is no need to postyour settings)
Are you playing from disk or image

Edit:When I gain control over my character in the begining of the game(in the fog),on my gpu with fps limmiter off I get
Native to 3x scaling 350-400fps
At 4x scaling I get masive speed drop of 100fps and since my gpu is twice better than your,4x may also be little too much for your gpu

Just for a test try native to see if the scaling is actually the problem(and no msaa...msaa actually work only in DX but it's huge fps killer)
Reply
#8
(06-07-2018, 05:53 PM)vsub Wrote: That's just GSdx
Did you change anything in HW hacks,what are your pcsx2 settings(if you are using preset 2,there is no need to postyour settings)
Are you playing from disk or image

I didn't touch HW hacks. It's at present 2

I'm playing from an image.
Reply
#9
Read my edit above
Reply
#10
(06-07-2018, 05:53 PM)vsub Wrote: That's just GSdx
Did you change anything in HW hacks,what are your pcsx2 settings(if you are using preset 2,there is no need to postyour settings)
Are you playing from disk or image

Edit:When I gain control over my character in the begining of the game(in the fog),on my gpu with fps limmiter off I get
Native to 3x scaling 350-400fps
At 4x scaling I get masive speed drop of 100fps and since my gpu is twice better than your,4x may also be little too much for your gpu

Just for a test try native to see if the scaling is actually the problem(and no msaa...msaa actually work only in DX but it's huge fps killer)

I'm not really sure if the scaling is the problem. I tried it at 3x at that are and it's fine. Same goes for 4x.

it looks like it's not lagging right now after restarting the program. 


I get 60 fps with limter off.
Reply




Users browsing this thread: 1 Guest(s)