Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
James Bond 007: From Russia with Love graphic issue
#1
Whenever there's an explosion this game shows it that way with D3D11 HW:

[Image: Ldpa2eF.png]


Which is totally absent in software mode. Is this a known bug or I am configuring something wrong here?

I am using the last build from here:
http://buildbot.orphis.net/pcsx2/


Also, the game will freeze if we use the default settings (2) 

[Image: VciQJPu.png]


I tried "3" and it worked just fine.
Reply

Sponsored links

#2
Potentially it's a depth emulation issue, does the issue happen in OpenGL hardware renderer?

Quote:Also, the game will freeze if we use the default settings (2)

Which version of PS2 BIOS do you use?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
I had this problem with Terminator Dawn of Fate. Switching to Open GL HW fixed it for me.
Reply
#4
(02-19-2017, 06:09 PM)ssakash Wrote: Potentially it's a depth emulation issue, does the issue happen in OpenGL hardware renderer?


Which version of PS2 BIOS do you use?
Using OpenGL Hardware forces the game to become slow, and this still happens. The BIOS I am using is v. 02.20 (Japan), from September 5, 2006, I believe.

Even if I select Native (instead of 3x the Internal Resolution), the Open-GL Hardware is still slow for this game.

Selecting D3D 11 HW the game runs without any slowdowns.

And switching to D3D11 SW this bug doesn't happen.
Reply
#5
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
Quote: Selecting D3D 11 HW the game runs without any slowdowns.
Because half of the rendering is skipped. So yes it is fast but broken ... However you might still have an "half screen" bug with openGL.
Reply
#7
(02-20-2017, 08:19 AM)jesalvein Wrote: Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

This is what I could find...


Attached Files
.txt   emuLog.txt (Size: 15,6 KB / Downloads: 31)
Reply
#8
OK.was wondering why you were getting slowdowns in OGL mode

perene Wrote:Using OpenGL Hardware forces the game to become slow
emulog Wrote:GPU: AMD Radeon R7 200 Series
emulog Wrote:The OpenGL hardware renderer is slow on AMD GPUs due to an inefficient driver
so i guess your only option is D3D SW mode for now...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
(02-20-2017, 04:35 PM)jesalvein Wrote: OK.was wondering why you were getting slowdowns in OGL mode

so i guess your only option is D3D SW mode for now...
No, I can use D3D HW 11 mode, it won't slow things. SW mode will make any game look ugly, unless the game requires it to work (Spider-Man 2 is a good example).

Have you (or any of you) tried to play this game and get to this part? It's right in the beginning. You can use these PNACH codes to enable cheats, if you want to get there easily:
http://pastebin.com/yLDvvT10

Just rename the TXT to 22DC8EAC.pnach and put that Pastebin text in it.

I saw that comment in my log (about the driver), does it really mean my video card is messed until they fix and this is a side effect?

I am curious to see if someone else can reproduce this problem. I thought it was another game issue, not related to my video card model or some emulator config.

P.S. And if I am not mistaken, while using the OGL HW renderer the game wasn't slow, however it became that way after a while.

Found a thread explaining a few things:
https://community.amd.com/message/2756964

Just to elaborate slightly on this (as I am one of the developers for PCSX2), this performance drop is consistent across the entire AMD range, regardless of computer specs.

OpenGL performance is usually roughly half that seen on DX11 using the same card/setup.

On Nvidia cards the performance of OpenGL vs Dx11 is about the same, sometimes it is 1-2% slower in OpenGL, but generally is the same speed.

So there is certainly an issue with the driver, one of our guys who works with making hardware for a living, also works on GSDX, said the OpenGL driver seems very single threaded, where Nvidia have a multithreaded driver for OpenGL, this wasn't obvious until he enabled the multithreaded support on GSDX when initialising OpenGL, that is when the gap between the card manufacturers appeared.
Reply
#10
this error happens in D3D HW mode.
not in Opengl, nor in D3D SW mode

In D3D SW mode, you can run it without glitch, but it requires a beefy CPU, and you can't upscale
In OGL mode, you can run it without glitch, and can upscale.
Unfortunately, since you have an AMD GPU, OGL will be slow.

That's why you have no other choice than using D3D SW mode for now, or playing it on your PS2.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)