Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Legaia 2 after battle graphics glitch.
#1
Hey, I've already gone through all of the other Legaia 2 threads here, and a few I found on other sites and a couple Youtube videos. The first issue I saw was the black grid over the opening FMV, which was fixed easy enough by going back to Native resolution. I also made sure to reset everything back to default, and where people said to "uncheck" something, I went into the options and made sure it was unchecked. Everything is where it should be according to every thread I've seen about this game.

So I start up the game, opening FMV looks great, frame rate is great, actually running at 100%, everything looking good. I go through the opening stuff, walk around town, and everything's fine. Then I get to the first area with enemies(forest outside of town) and things are still looking good. There's a tutorial battle, and it runs smoothly. Then it cuts back to you in the forest, and . . .

The map's all wrong. It's just you standing on a featureless green and gray background. You can kind of see where grass, water, etc. is supposed to be, but it's all flat and missing details and ugly and hard to navigate. I managed to find my way mostly by luck to where the 2nd tutorial battle happens, hoping that might fix things. The battle looked great again, but it didn't fix anything. When the battle was over and it was back to your character running around the map, it was still all glitched out.

Anyone know what's going on? I've seen people complain about graphics and frame rates, but nothing like this. And I'm curious why the glitch didn't happen until after a battle, because up to this point everything had been looking good.
Reply

Sponsored links

#2
I don't remember such problem
I have the game but I can check tomorrow
Reply
#3
Can you show me what you mean because I don't see any problem after battle.
And also,the game don't have some amazing graphical features for the areas.For the most part,you are walking over an image
You can also try the latest beta
https://buildbot.orphis.net/pcsx2/
Reply
#4
Just got the email notification. I'm about to sleep, but I'll get a couple screenshots tomorrow.
Reply
#5
Ok, I got some screenshots that'll hopefully illustrate what's going right and where things go wrong. Again, I'm using the default settings, native resolution, and no hacks(made sure to go in and uncheck anything that the other threads said shouldn't be checked).

So first up is the FMV. I was having the grid problem when I tried to do a custom resolution(2048, which I use in other games to make them look a little better). Switching back to Native 1024 fixed it, so you can see here it's working fine.
   

Then after starting up the game, you can see that wandering around the town is also just fine.
   

Here's a small section of the forest area where you have your first tutorial battles. I chose this spot because it has a lot of stuff. Grass, trees, rocks, running water(trust me; it looks better on screen than in a static screenshot), etc. Again, it's looking good.
   

And here's a shot from in battle, where everything is still fine.
   

And here's what happens after battle. When it goes back to the area map. This is the same area as the BeforeBattle screenshot above. Notice the flat, drab colors, and the utter lack of detail. No rocks, no flowing water, no grass, no trees. It's what I assume is the base layer of the entire map that everything else is stacked on to get the final effect, but all that other stuff is just gone. It also doesn't affect the character - he looks fine. And I didn't screenshot it, but opening menus works fine, too. It's just the area map that's giving me issues.
   

And that's it. Everything works great up to that point, and most things that I have access to still work fine after. It's just the area map that gets all glitched out and I don't know why. Especially since it was just fine before the battle.
Reply
#6
I didn't tried dx11 yestarday(I tried dx9 and ogl) but if you are on nvidia gpu,try using opengl
Are you using any widescreen patches or cheats.
You can also try the latest beta from the link I posted above

I will be able to check the game again after 10 hours(if I don't forget)
And you are using the default gsdx setfings right?
I get some werd problems while messing with the hw hacks in gsdx
Reply
#7
I've been using the 11 Hardware as instructed. Default settings. No cheats. No hacks. No patches.

I haven't started the game on 9 on opengl(the only other 2 options I have), but switching to them after the glitch doesn't fix anything. I did try that. Also, should I use hardware or software versions? Is there even a difference?

And what's gsdx? I don't recognize that, but whatever it is, I didn't mess with it. Default settings all the way.
Reply
#8
Also, here are the PC specs I could find.

OS: Windows 10 Home operating system
System: PSSM-UD2, x64-based PC
Processor: Intel® Core™ i5 CPU, 750 @ 2.67GHz, 2661MHz, 4 Core(s), 4 Logical Processor(s)
Physical Memory Total/Available: 8GB, 7.99GB
Virtual Memory Total/Available: 9.24GB, 7.48GB

Then the video card.

AMD Radeon R9 200 Series
Chip Type: AMD Radeon Graphics Processor (0x697A)
DAC Type: Internal DAC(400MHz)
Device Type: Full Display Device
Total Memory: 7143 MB
Display Memory: 3052 MB
Shared Memory: 4091 MB

That's all the stuff that looks relevant.
Reply
#9
"As instructed",by why,not some youtube video right?

GSdx is the video plugin which you open to choose the renderer mode(DX11)
It could be possible to be AMD specific problem.

I am using the default settings on the latest beta(download the latest beta and run the game without configuring anything exept the bios and my memory cards location)and the game looks the same before and after any number of battles.

And I just tried the game again with DX11 on the latest beta and 1.4.0 and it still works

Can you post the emulog.txt file after the problem occurs.You can find the file in "My Documents\PCSX2\logs" if you are using the installer version of pcsx2 or in "PCSX2\logs" for the portable version.
Reply




Users browsing this thread: 1 Guest(s)