MGS3 hangs after kojima logo
I will be moving away from my house in a few months and will be leaving my PS2 at home. I'd like to be able to play my PS2 games while away so I started looking into PCSX2. I downloaded it and read through the official guide and my specs & conf are below:

Processor: i7-940 @ 3.2 GHz
RAM: 2x2GB @ 1333 MHz (see 32bit OS note)
Graphics: Nvidia GT 240 1GB
CD tray: LG Super Multi GH24LS50 (16x max DVD-ROM read)
PCSX2: 0.9.8 (r4600)
Game: Metal Gear Solid 3: Subsistence (Disc 1)
Game ID: SLUS_213.59;1
BIOS: USA v01.60(07/02/2002)
OS: Windows 7 Ultimate Service Pack 1 x86

gsdx 4600 0.1.16, using DirectX 10 hardware
lilypad 0.10.0 r4510,
SPU2-X r4600m 1.4.0,
cdvdGigaherz r4510 0.8.0, Reading Original Disc in Tray

My problem is that although the system boots fine into the BIOS (with 59.94 or 60 FPS) and loads the first few logos of the game itself (again 59.94 or 60 FPS) weird things start happening after the Kojima logo disappears. The GS% drops to zero, along with everything else. The FPS drop to 0.XX (between 0.12 and 0.45) and if I leave it long enough will actually shutdown the emulator. If I try to issue the shutdown command from the system menu PCSX2 will crash.

The only modifications I've tried are the clamping settings on EE/IOP menu because I don't know huge amounts about how to modify the engine. If anyone has gotten this game playing i'd love to know what settings you've used.

Sponsored links

Any errors listed in the console?

If I had to guess off the top of my head though you probably have a bad dump.
[Image: 2748844.png]
The game runs right past that part on my end, even using relatively default settings. (EDIT: My mistake, I overlooked the fact that you're using MGS3: Subsistence, I'm using the original.)

Perhaps changing what you did is your issue.

Otherwise, posting your PCSX2 settings may help.

Also, I highly recommend you make an ISO of the game disc using Imgburn, then mount it with the internal ISO Selector (under CDVD). This would also allow you the convenience of not having to carry your physical game discs with you. Wink
(06-15-2011, 09:29 PM)Koji Wrote: Any errors listed in the console?

If I had to guess off the top of my head though you probably have a bad dump.

I didn't see anything that obviously looked like an error. It kept repeating the Blue Text that reports the title of the disc a few times and that's it
Can you load the game, close the emu once it gets to that part, then copy-paste everything in your emulog.txt?
[Image: 2748844.png]
Ok Here's All my Settings as PNG's and my emulog.txt. The only relevant line I found in emulog.txt was this one

GIFTAG warning, size exceeded VU memory size 400

which was closer to the beginning of the game execution. Here is the full text:
PCSX2 0.9.8.r4600  - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
    Operating System =  Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 32-bit
    Physical RAM     =  3317 MB
    CPU name         =  Intel(R) Core(TM) i7 CPU         940  @ 2.93GHz
    Vendor/Model     =  GenuineIntel (stepping 04)
    CPU speed        =  2.971 ghz (8 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 0098e3bd
    x86EFlags        =  28100000

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
    Binding GS    : C:\Program Files\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GT 240 (
    Binding PAD    : C:\Program Files\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
    Binding SPU2    : C:\Program Files\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
    Binding CDVD    : C:\Program Files\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
    Binding USB    : C:\Program Files\PCSX2 0.9.8\Plugins\USBnull.dll
    Binding FW    : C:\Program Files\PCSX2 0.9.8\Plugins\FWnull.dll
    Binding DEV9    : C:\Program Files\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 216ms)
Bios Found: USA     v01.60(07/02/2002)  Console
HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GT 240 (
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
* CDVD: Opening drive '\\.\J:'...
* CDVD: IO thread started...
* CDVD: Disk Type: Double-Layer DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 2) (2282528 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: C:\Users\Me\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Me\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v01.60(07/02/2002)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
GIFTAG warning, size exceeded VU memory size 400
GIFTAG warning, size exceeded VU memory size 400
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.59;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_213.59;1) Game CRC = 0x053D2239, EntryPoint = 0x00852A68
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.59;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.59;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.59;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

Attached Files Thumbnail(s)

.txt   emuLog.txt (Size: 2,99 KB / Downloads: 171)
Yeah, you can just ignore that "GIFTAG warning". Smile

Well, I can't say I see something wrong there, but I do see one thing I'd try doing differently if in your position.

Download the PCSX2 Binaries, and extract them to a custom location (i.e. "C:\PCSX2\"). Basically, this will avoid "Program Files" and "My Documents", which can cause issues due to the potential for resticted access.
Will do, I am running it as an administrator to avoid some of those issues, but I will uninstall / decompress into a directory with no spaces to see if that resolves anything.
//EDIT: Installed to C:\PS2 with Bios files in C:\PS2\BIOS and (mostly) default settings. The only deviation form the defaults was to set DicrectX 10 hardware and Native Resolution is GS. MGS3 did the same thing so I tried We <3 Katamari (SLUS_212.30;1) which is also listed as playable and it's working wonderfully. So it seems like MGS3 is assuming some non-standard hardware behavior that the emulator is not replicating for some reason. /EDIT

In reference to the error(s), what component of the emulator is that and do you have any idea what it means? If I knew what a GIFTAG is I would be better able to figure this out on my own.

You are running the game from the actual disc which could be the problem. It's recommended that you run the games via disc images on your hard drive, especially ones that stream a lot of data from the disc. Use a program like imgburn and make a disc image and run that via PCSX2's native disc image loader.
[Image: 2748844.png]
Strange. The NTSC version is listed as playable with PCSX2 0.9.8... Blink

At that point, I would see if it works on an older version, myself. Maybe see if it happens to go past that point using PCSX2 0.9.7.

On the GIFTAG error: I have seen this before, with several games that haven't such issues. I could almost guarantee you that it's unrelated to the problem you're having. You honestly can ignore it. Smile

@ Koji:
I'm guessing/hoping he's already done that. If not, having 2 people recommending it should be rather encouraging to do so.

Users browsing this thread: 1 Guest(s)