Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mouse focus
#1
When i disable 'Start without mouse focus' and play a game it works fine. But when i press escape to adjust some settings the pcsx2 menu doesn't show my mouse. The only solution is to exit pcsx2 which is pretty annoying because my paused game would be gone.

Is there any way to fix this? I don't have a controller so i need to adjust the key bindings a lot.

Thanks in advance..
CPU: AMD Phenom ii x4 955 @ 3.4Ghz
GPU: MSI GTX 560-Ti Hawk
RAM: Kingston ValueRam 4GB 1333 @ 1600
PSU: XFX PRO550W

Reply

Sponsored links

#2
you need to toggle again the "mouse mode" where you bind it. to turn off the mouse mode and bring the mouse cursor.
*this is during emulation
*closing or pressing the ESC key during emulation and the mouse mode is on. you will lose the mouse cursor for the rest of your windows section forcing you to restart your PC w/ the reset button on your desktop,forced shutdown (holding power button).
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
Ah okay i get it.. so for people who have same problem:
- Go to your key bindings/configuration
- Bind the button "Mouse" to a key
- Start the game with "Start without mouse focus" disabled
- Before you press escape, press the key you bound to the "Mouse" button and the ps2 game will lose the mouse focus.

Oh and it's not a disaster, you just have mouse focus outside the pcsx2 menu and even if not you can press alt-ctl-del and go to pcsx2.exe with your keyboard and close it with del.
CPU: AMD Phenom ii x4 955 @ 3.4Ghz
GPU: MSI GTX 560-Ti Hawk
RAM: Kingston ValueRam 4GB 1333 @ 1600
PSU: XFX PRO550W

Reply
#4
(01-16-2014, 01:20 PM)dutch_coffee Wrote: Oh and it's not a disaster, you just have mouse focus outside the pcsx2 menu and even if not you can press alt-ctl-del and go to pcsx2.exe with your keyboard and close it with del.

Or just Alt+F4
Reply
#5
FWIW, I pushed a change which should make all of these hoops not required anymore.

Now after pressing escape or alt-tab to another window, mouse cursor should now return to normal. I also fixed an issue where after alt-tab to another window and then back to gsdx (regardless if lilypad was set to capture mouse or not) - pcsx2 shortcuts (like escape or F6 etc) were not working, and now they should work. http://git.io/voMq4Q
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply




Users browsing this thread: 1 Guest(s)