Need help, cant play on emulator
So I downloaded the emulator, with the controller adaption lilypad, configured all that and it worked perfectly, downloaded a Bios set, although I'm a bit inexperienced with emulators so don't know 100% what BIOS i should be using but I used a European one and tried to get Sims for the PS2 working, It gets all the way to the character customisation part and either crashed when I try to switch between male and female, or crashes as I try to leave the window to go to the next customisation menu, basically it just crashes 100% of the time on the character customisation, I've tried everything and can't seem to get it working, any help please?

Sponsored links

(06-06-2015, 02:28 AM)Kybet Wrote: downloaded a Bios set,

Using a BIOS file with PCSX2 which you have downloaded from the internet or from a PS2 console you do not own is illegal. You must own the console the BIOS file came from (even if it's broken) to be legal.

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!

Users browsing this thread: 1 Guest(s)