Need help from someone who understands PS2 and PCSX2 well
#1
I'm trying to get a demo game to work without it booting back to the browser menu.
I already fixed the browser menu boot, but the demo still has an issue that doesn't allow it to load back to the menus of the game. If anyone with knowledge in PS2 and PCSX2 could see what's wrong, I've attached two images to this. The other one is the error from PCSX2 console, and other one is a picture of the region where the issue is coming from in PS2DIS. Does anyone see an issue with any of these highlighted parts?
(Does the addr=0x0 and addr=0x1 point to any specific addresses that have problems?)


Attached Files
.png   Capture102.PNG (Size: 54,16 KB / Downloads: 120)
.png   Capture101.PNG (Size: 3,33 KB / Downloads: 90)
Reply

Sponsored links

#2
Which demo you are trying to run? You got that TLB miss with some patches applied, or using not modified image/disc?
Reply
#3
(08-06-2019, 07:41 AM)kozarovv Wrote: Which demo you are trying to run? You got that TLB miss with some patches applied, or using not modified image/disc?
It's Gran Turismo 3 OPS2M PAL Demo. This error appears everytime in the console when you leave a race, even unmodified. Only thing I changed was that the game doesn't send you to the browser menu. I don't understand the commands and such too much, so if someone notices something wrong in that picture, then help is welcome. When leaving the race, the game just freezes.
Reply
#4
(08-06-2019, 07:45 AM)Miskaroni Wrote: It's Gran Turismo 3 OPS2M PAL Demo. This error appears everytime in the console when you leave a race, even unmodified. Only thing I changed was that the game doesn't send you to the browser menu. I don't understand the commands and such too much, so if someone notices something wrong in that picture, then help is welcome. When leaving the race, the game just freezes.
If you changed code somehow, then that is probably your issue. You was talking earlier about removing some syscall, which is bad idea for sure. 

If you got tlb miss on unmodified disc, that you are sure is working correct. You can try set different clampings, and EE timing hack.
Reply
#5
(08-06-2019, 07:56 AM)kozarovv Wrote: If you changed code somehow, then that is probably your issue. You was talking earlier about removing some syscall, which is bad idea for sure. 

If you got tlb miss on unmodified disc, that you are sure is working correct. You can try set different clampings, and EE timing hack.
The issue happens even with an unmodified disc. I can try clampings and such, but don't think it's gonna help. Experimenting with removing syscalls actually did nothing and everything worked like normal.
Reply
#6
I dumped this demo now, and I don't have that TLB miss, look like you have bad dump, or you modified something that trigger it. For me game quit to browser after time limit is reached.
Reply
#7
(08-06-2019, 08:37 AM)kozarovv Wrote: I dumped this demo now, and I don't have that TLB miss, look like you have bad dump, or you modified something that trigger it. For me game quit to browser after time limit is reached.
I doubt that I have a bad dump, but I'll try on another one.

-EDIT
Yeah, it happens on unmodified discs as well. The TLB miss gets lost in the console though, as it outputs a lot of stuff when it takes you to the browser. Browse up on your console and look for red text.
Reply
#8
Yeah, now i see it. I tried different clampings, and some hacks. Nothing helps. Also tried break at that point in debugger, but this runtime is part of loop that is running all the time. So is hard to catch that moment. TLB hack gave some debug output, maybe it will be useful.
Reply
#9
I know a cheat that disables the AI. Are you trying to access the hidden contents of the game? That's probably the only case I can find where you can get problems. For me, the game freezes and I need to disable the AI cars.
PC Specs:
PC: HP Omen 15 dc-0051nr laptop
CPU: Intel i7-8750H (2.2 GHz up to 4.1 GHz)
RAM: 16 GB
GPU: Nvidia GeForce GTX 1060 Notebook (6 GB)
OS: Windows 10 Pro (64 bit)/Windows 8.1 Pro (64 bit)
Storage: 256 SSD PCi NV M.2+1 TB HDD
Need the latest GIT/development build? Click here!
Reply
#10
(08-07-2019, 07:42 PM)gtgamer468 Wrote: I know a cheat that disables the AI. Are you trying to access the hidden contents of the game? That's probably the only case I can find where you can get problems. For me, the game freezes and I need to disable the AI cars.
No, it's not that. I'm just trying to modify the demo so it can be played like normal, without it freezing/booting back to the browser menu. The command to boot back to the browser I already fixed/removed, the problem now is the game having a TLB error which freezes it.
Reply




Users browsing this thread: 1 Guest(s)