Need help setting up PCSX2... Please (pics in attachments)
I have no idea where/how to set the Bios directory. When I try to load a game I get a message saying the bios was not found. (image in attachment)

System Specs:
OS: Win7 Ultimate 64
CPU: i7 920
Mobo: ASUS Rampage II GENE
RAM: 3GB G.Skill

Attached Files Thumbnail(s)

Sponsored links

Should I support him ? LOL at the "This copy of Windows is not genuine" Tongue
Download the emulator from the official site. I guess that you downloaded it from the other site. (That hacks or modify the code inside PCSX2)

For better quality, use the latest beta emulator and plugins.
Get them here
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit

Acer Aspire 4750G
*cleaned up 1st post*

Thank you for the link. Wherever I downloaded PCSX2 before had a bogus version. I'm still having trouble with setting up the Bios though. Could really use some help...
I thought it is quite obvious.

Attached Files Thumbnail(s)
AMD Athlon II 245 @ 3.55ghz, 9600GT @730mhz 1115mhz, vista sp2 32bit
I have no idea where to go from there though...

I just tried PCSX2/Bios but something went wrong somewhere... (I can't read whatever is on the emulator window)

Attached Files Thumbnail(s)
Ok I am sooo lost. I have a Final Fantasy 10 .iso file. (yes I own an actualy copy).

- Tried to go to run\execute but I get a message saying "Error loading C:\Users\Eric\My Documents\My ISO Files\FINAL_FANTASY_X.ISO
- Tried to mount the FFX.iso then using File\Run DVD/CD. A window pops up with a lot of "isoReadBlock: ########" (attachment 1)
- Tried File\Run ISO Image... but I get a error message about the format. (Does this mean the emulator is functioning properly? My ISO file is just junk?) (attachment 2)

Attached Files Thumbnail(s)
well i dont know... try reconverting your iso from your game disc again using imgburn (google it) and be sure its not been used by any program when you open it with pcsx2
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Apparently, you need to do some reading since you are so lost.

If you are still lost after reading it, you will need to do more reading.
AMD Athlon II 245 @ 3.55ghz, 9600GT @730mhz 1115mhz, vista sp2 32bit
Looks like you pointed the ISO loader to the file inside the disc and that's the incorrect way to do it. Since you have a .iso file you should point pcsx2 to the big final_fantasy_x.iso file and not any other, make sure it's unmounted from other software.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64

Users browsing this thread: 1 Guest(s)