Need help with save states
Whenever I make a save state, in slot 0 for example, and switch to another game that has a save state for slot 0, it will load up the first game.

So if my save states were layed out like this:

#1 Dark Cloud
#2 Dark Cloud 2
#3 Graffiti Kingdom
#4 God of War II
#5 Final Fantasy XII
#6 Resident Evil 4
#7 Final Fantasy X
#8 God of War
#9 Persona 4

Then if I opened God of War, and made a save state for slot 2, it would over write Dark Cloud 2's save state.

I looked this issue up, and it seems that PCSX2 should be saving these files using the games CRC, but i looked in my folder, and all of the save states were called BIOS (00000000).<slot #>. I'm guessing that's what's messing up, but I want to know how to make my save states save using the games CRC so that I can have multiple saves for one game. Thanks in advance.

Sponsored links

Looks like pcsx2 don't get the game crc when you use Full Boot

Using System=>Boot CDVD(fast) will fix your problem but this isn't supposed to happen
You are probably trying to load/save too fast, before PCSX2 had a chance to open the ELF of the game and read the CRC. Also each game has all 10 slots, so whenever you boot a game all slots are for that game only and the same if you change a game, so the pattern you posted above is not possible (different games in different slots)
[Image: newsig.jpg]
I actually tried this before posting...I just started a game using Full boot,wait for something of the game to appear(the first logo or movie)and then press F1.
The save state that was created in the sstates folder was named "BIOS (00000000).00.p2s"
I just tried it with Gran Turismo 4 and It worked fine?
Saving savestate to slot 1...
filename: G:\PCSX2\sstates\SCES-51719 (0086E35B).01.p2s

Maybe try waiting a bit more.
[Image: newsig.jpg]
Looks like the problem is pcsx2 and old PS2 bios...with my V6 PAL PS2 BIOS I get this result but with my V12 PAL PS2 BIOS everything is fine
Hm not sure which are V6 and which are V12 but mine is PAL v01.70 and it works...
[Image: newsig.jpg]
V6 - 1.60
v12 - 2.00
So since it works on mine it's not that Tongue Hm it's not the game region either since I tried it on a NTSC game with my PAL bios and it still worked...
[Image: newsig.jpg]
On the 1.60 there are lot of thing that are missing from the console compared to the what I get when I use the v2.00 bios(the game elf and the crc is missing from the console when I use 1.60)

Users browsing this thread: 1 Guest(s)