Not using GPU with Bumblebee
Hi everyone.  I'm running into an issue where PCSX2 is using the integrated gpu on my Intel i7 processor on my laptop instead of my discrete NVIDIA gpu.  Here's my specs:

OS: Fedora 28 x86_64
CPU: Intel i7-4702MQ
PCSX2 version: 1.5.0-dev-3126-g2941fd9b8 (git pull from today)
GPU Driver: 418.56 (proprietary)
RAM: 16 GB

I built the software with the command: --release --clean
It compiles and runs, but when I launch with: primusrun bin/PCSX2, optirun -b primus bin/PCSX2, or using bin/ games run slowly.  I have the GS plugin set to OpenGL(Hardware).  The log shows:
Opening plugins...
Opening GS
OpenGL information. GPU: Mesa DRI Intel(R) Haswell Mobile . Vendor: Intel Open Source Technology Center. Driver: (Core Profile) Mesa 18.0.5
INFO: GL_ARB_sparse_texture is NOT SUPPORTED
INFO: GL_ARB_sparse_texture2 is NOT SUPPORTED
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_compute_shader is available
Failed to init the freetype face
INFO: GL_ARB_shader_storage_buffer_object is available
INFO: GL_ARB_texture_view is available
INFO: GL_ARB_vertex_attrib_binding is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_multi_bind is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
INFO: GL_ARB_get_texture_sub_image is available

Current Renderer: OpenGL (Hardware renderer)
which clearly shows the discrete GPU is not being used.  Other applications launched with primusrun or optirun -b primus do utilize the GPU (like glxgears and glxspheres).  Does anyone have any suggestions?  This used to work perfectly with primusrun in the past.  Thank you!

Sponsored links

Might be the easiest way to disable the Internal Intel GPU in your BIOS/UEFI, if you don't need it. This should force the use of your NVIDIA.
Tired of always changing your PCSX2 Configuration for different games?

Check this out:
I'm not actually sure if my BIOS/UEFI supports that or not.  Thanks for the suggestion, I'll surely check it out and see if it's possible.
For what it's worth, I created a new issue in Github ( for this after I bisected the commit history.  Commit 694546e87 is the last working for me, while the next one, da1eb056a, introduces the problem.  Not sure why because that commit doesn't seem to have anything to do with GSDX that I can tell.

Users browsing this thread: 1 Guest(s)