Pcsx2 random freezes
Hi everyone! I've ran into this problem before, but it still exists as of rev5068: when playing a game (ANY game). Pcsx2 freezes and throws a "Pcsx2 has stopped working" message after about 30-40 mins, but not at a particular point or scene (it happened during loading, cutscenes, gameplay, etc.). It happened on 2 different computers (specs below), and I've ruled out EVERY SINGLE non-default thing that might cause it.

- I used a 8MB memcard instead of the 32MB I normally use, and it still happened.
- Speedhacks are all off
- Interlacing off, native resolution, DX11, DX10 and DX9 were all tried, to no avail.
- Didn't use savestates.
- No overheating on either PC or Laptop

PC 1:
Intel Core2Duo E7200 @ 2,57 Ghz
AMD Radeon HD3650 512MB
Win7 Ultimate 32-bit

PC 2 (laptop):
Intel Corei5 480M @ 2,67GhZ
AMD Radeon HD6370M 512MB
Win7 Ultimate 64-bit

Here's a full list of games it happens on (various regions, but no (J))
Final Fantasy XII
Disgaea 2
Shin Megami Tensei Nocturne, Digital Devil Saga 1/2 and Persona 4
Crash Bandicoot 4
Phantom Brave
Kingdom Hearts 1/2/Re:com
Lord of the rings: the third age
Shadow the Hedgehog
Xenosaga 1/2/3
Rogue Galaxy

cdvdGigaherz (but I use ISO loading most of the time)
USBNull, FWnull, Dev9Null

This problem persists for over a year, and it didn't happen before. Please, someone help me, because PCSX2 is unusuable this way.

Sponsored links

Check it :-
  • Did you check you Task Manager? How many processes. Also, check the Graphics Card. Whats the EE/GS% when you get this error?
  • Try using pcsx2 0.9.7 or 0.9.8. They might be better.
Any detailed info on the error? If it feels completely random and in every game I would guess it's caused by Xaudio output, soo go into SPU2-X config and change module from Xaudio2 to DirectSound.
Wow, it... seems to work! PCSX2 has been running for 1 hour without a freeze! Thank you!
Nice. Have fun playing your games on pcsx2. Hah, I never would have thought that changing the sounds plugin would solved this random error/crash because I really never had an issue with the sound plugin before. Nice one miseru99.
update your sound drivers to fix xaudio

Users browsing this thread: 1 Guest(s)