Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Performance loss over the years
#1
Hello. First of all, thank you for all the work put on this emulator.
I am using this emulator for many years, with very varied results, always playing it in this computer.
My problem is this, during 2013 and 2014, i used this emulator on this computer in a windows 7 partition that was profesional (bootcamp). I guess at that time i used version 0.98 (but i am not sure), and games like Final Fantasy XII, Katamari, Silent Hill 2, Resident Evil 4 and Macross Do you remember Love ,worked really well, graphics and sound!.

But, when i upgraded my computer (new hdd and a ram increase), i could not configure it correctly and all games played awfully slow. I updated to 1.4.0 in 2015-2016 period and worked kind of so so in a better way in games like FFXII, but nowhere near the previous experience.

Unninstalling and reinstalling differente versions of pcsx2 (trough 0.98 to 1.60), i could not make it work properly, or at least in a good speed. It was very frustrating.

And this year i proposed to fix this issues once and for all. But i have failed until now.

I am lost because if tried lots of different configuration, and i cant achieve the very good results i used to have. I dont know were to ask and this is the only place i think i can get a proper answer. Specifically the question is "Why the emulator worked great before and now i cant make it work properly?".

Sorry if i am braking rules or if this question does not apply.

Thank you very much in advance.

This are my specs


MacBook Pro (13-inch, Mid 2012)
Processor 2,5 GHz Intel Core i5
Memory 8 GB 1333 MHz DDR3
Graphics Intel HD Graphics 4000 1536 MB
Using Bootcamp
Windows 7 Ultimate
Direct x11 support
Reply

Sponsored links

#2
so :
- It's a Macbook from 2012, means it's more 50% more expensive and 50% less powerful than a gaming PC from that era.
- Emulation basically needs a beefy CPU, pcsx2 generally needs a beefier one
- As time goes by, pcsx2 increases its accuracy, meaning it needs a globally beefier machine (CPU and GPU)
- Using Win7 means you'll be stuck with 1.6. next releases won't work on it.

All this doesn't sound good, but, can you please post your pcsx2 settings, gsdx settings, as well as your emulog.txt, please ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
The newer version of pcsx2 has overkill features therefore hardware/software requirement increase.
Your laptop too weak to keep up.
OS: Windows 10 Home 64 BIT 20H2
CPU: AMD R7-3700X 3.6 GHZ
GPU: Asus GeForce GTX 1650 Super
RAM: Corsair 3600 MHZ 2x8GB DDR4
Mainboard: Gigabyte B450 PRO WIFI
Display: Asus VP228
Audio: Creative Sound Blaster Z / GigaWorks T40
Storage: Seagate 1TB HDD, Transcend 1TB SSD
Optical: Asus BW-16D1HT Blu-Ray Writer
Power supply: Corsair CX550M
Reply
#4
First of all, thank you for answering.

Well the macbook buy was because of work issues, it was not oriented to gaming but it evolveld that way lately. PS2 is the last barrier in my emulation shenanigans.

Well, right now i went back to version 0.98, because it is the one right now, that works better than the other versions.

Please, take in consideration that i am by no means an expert t user.

This is my configuration right now.

BIOS: USA v02.00 (2004)

EE/IOP
Emotion Engine: recompiler
IOP: recompiler
EE/FPU: zero
Pincer mode: none

VUs
Vu0: recompiler microVU
Vu1 recompiler microVU
Round mode: zero
pincer: none


GS
framelimit: disabled
Frame skip: disbled

window
4:3
window 640 x 480

Hacks
enabled

cycle speed EE : 1
VU cycle theft : 0

INTC spin activated
loop stop detection activated
Mvu layer fix enabled
Mvu block enabled


Video Plugin:
GSDx 4600 (msvc 15.99 sse2 0.1.16

Directx 9 hardware (directx11 had a little less performance)
Native resolution
8 bit textures allowed.


SPU2-x
Linear (simple/ok)
1x normal reverb volume

Xaudio2
Timestretch
stereo





Emulog (if this is incorrect please reply)



PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 8098 MB
CPU name = Intel® Core™ i5-3210M CPU @ 2.50GHz
Vendor/Model = GenuineIntel (stepping 09)
CPU speed = 2.493 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7fbae3bf
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
Binding GS : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Intel® HD Graphics 4000 (10.18.10.4226)
Binding PAD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 845ms)
Reply
#5
ok. you cpu has an STR under 1600 and that gpu is clearly crap.
added to the fact 0.9.8 is unsupported, I don't know what to advise you apart from keeping playing on your PS2 until you can afford a suitable rig
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
(04-14-2021, 11:38 PM)jesalvein Wrote: ok. you cpu has an STR under 1600 and that gpu is clearly crap.
added to the fact 0.9.8 is unsupported, I don't know what to advise you apart from keeping playing on your PS2 until you can afford a suitable rig
Thank you for answering.
My question is, why it worked so well before and now i can´t go back to that performance.? If then it could play well, why not now? All the other games and emulator in this computer work great. Do you have any ideas? maybe some of them could work for me. Thus specs are crap, but for some reason, it worked really well (even in 2019, i managed to tun FF XII very well, not so the other games). Maybe a later build could work, 1.4 gave me hope for a little, and sometimes 1.6 too, but 0.98 got the better overall.

Some advice that i could check would be really apreciatted.

Thank you for your time and work.
Reply
#7
IIRC FFXII has been playable since 0.9.6. so, it's not surprising.

I'd say you could check you windows power plan and set it to performance mode if not done yet.
that could explain your problem since you're on a low end laptop
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
You just lucked out on PCSX2 version and games, while it may seem it gotten worse performance wise but v0.9.8 had quite some broken things in the 4000 or so games.
Either stick to old version or get better hardware.
Reply
#9
Thank you.
Reply
#10
Hello,
Well, today was the day. After going to 1.4, (it almost did the job), i went back once again to 0.98, and... it Worked!! i mean really worked!, near perfect emulation!. I am so happy, it is silly, but man i was long time trying :`)

i think the key was using direct x 9 hardware, the ss4 gs plugin, no speed hacks but multicore hack enabled (i guess this were the elements that made all work). Before that i was getting there but with flaws. After this, all worked well.

Well , we mac users with mid 2012 macbook, can still do it lol.

Thank you for your answers anyway, and for the disposition to help.
Reply




Users browsing this thread: 3 Guest(s)