Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved-Workaround [Bug Report] Sly 2 - Band of Thieves
#1
PCSX2 Version: 1.2.1
CPU Options: Defaults
Plugins Used: Default (GSDx, SPU2-X, LilyPad)
Description: In Sly 2, Episode 2 Mission 1 titled Recon the Ball Room you have to take pictures of certain objects in the ball room without getting too close to the guards. The electric winch at the top of the ball room, no matter how close I get or how far I zoom is always just a bit too far away to take a picture of. This bug was resolved by downloading Version 1.1.0 of the emulator and playing with that, using all the same settings and the same save file

Sponsored links

#2
This bug is legit, based on OPs previous thread. His issue is solved by using old version, but I told him to make a bug report.

Do you think you could try to find the specific revision that broke it, using builds from buildbot.orphis.net?
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#3
Just downloading old versions and trying the same spot in the mission over and over again until it fails, you mean?
#4
Yep. You can do it in like 20 build increments at first to save time. Then when you find a broken one, step back in 1s til you find the exact one.

It will help us to fix the actual problem.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#5
Yeah sure, I'll report back when I find the direct cause

EDIT: In this build: v1.2.1-598-gfd7b692, which is the most recent build with a download link the issue is resolved. I went back to the "consumer" edition of 1.2.1 and tested it just to make sure I wasn't crazy and, in fact, in that version the bug exists and in the one I just mentioned it does not.
#6
May I just ask for clarification?

1.2.1 doesn't work.
In v1.2.1-598-gfd7b692 it is fixed.
In v1.2.1-596-g39491f7 it is still broken?

This seems a bit unexpected since v1.2.1-598-gfd7b692 was a code cleanup and should not have changed anything...

Edit: Well the comment says its and code cleanup.. The code looks to me like something was changed in superVU, microVU and some other components but maybe I am wrong.
#7
I only downloaded one build off of the "in development" page. Didn't work in the main release on the home page, worked in V 1.1 and worked in version 1.2.1-598-gfd7b692 from the dev page.
#8
So, to confirm, the very latest build works?

http://buildbot.orphis.net/pcsx2/

Try #639

If it's resolved there then we can make a note in the compat list that you need the latest GIT for this game.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#9
I will check as soon as possible. Unfortunately I continued to play the game after that point and it would be pretty hard to test as I'd have to play another 2 hours or so of game. I do have a save state in the correct place though, is there a way to port this from the consumer version to this dev build for testing purposes?
#10
Savestates sometimes change with version, sometimes not. It might be compatible. But we generally don't recommend testing with save states, because they can "save" the error too.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ




Users browsing this thread: 1 Guest(s)