Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] klonoa 2 lunatea's veil Keeps crashing
#1
I apologize for the necropost: Google shows this thread first on the list so I figured it would be best to reply to this to potentially help others with the same problem.

I run into the same issue, on stable (1.4.0) and revision ba1689f. (v1.5.0-dev-2418-gba1689f6d).
I'm running the NTSC version of the game, dumped to an ISO format.
The logs are attached to this post.

.txt   emuLog.txt (Size: 7,16 KB / Downloads: 22)
.txt   emuLog gba1689f6d.txt (Size: 6,43 KB / Downloads: 22)

Hardware:
  • AMD Ryzen 5 2600X clocked at 4GHz
  • G.Skill F4-3200C16D-16GTZB (16GB) clocked at 3200MHz
  • AMD MSI Radeon HD 7970 Lightning BE Boost edition with 3GB of GDDR5 VRAM, on stock speeds
The issue occurs on both untouched settings, and with patches and custom settings applied, and on DX9, DX11 and OpenGL.
The patches I use are listed on https://wiki.pcsx2.net/Klonoa_2:_Lunatea%27s_Veil. I do want to note only one of all patches listed on the site (in this case the first listed 2F56CBC9.pnach, which applies to work around a hang in Volk City, a place I haven't been able to visit yet.

Please tell me if I need to provide any more debugging info. Thank you in advance.
Reply

Sponsored links

#2
Can you post the patch you are using?

Also did you try loading without savestates?
Reply
#3
I'll upload the patches to this reply.

.pnach   2F56CBC9.pnach (Size: 100 bytes / Downloads: 132)

.pnach   7EBEEBBD.pnach (Size: 88 bytes / Downloads: 78)

.pnach   1645DE53.pnach (Size: 123 bytes / Downloads: 71)

I haven't been using any savestates in my playsessions.

I've been doing further investigation and according to this thread, patch 2F56CBC9 should be solving this door crash issue. It seems like the patch is no longer working.
I'm clueless as to what I am supposed to do to have the workaround working, or the other patches aside from 2F56CBC9.
Reply
#4
As this post suggests, I'm gonna want to use an older development version of PCSX2, preferably 2175. However, the development releases list and the Windows builds do not show anything older than three or four weeks old. Does anyone have this build available somewhere?
Reply
#5
https://buildbot.orphis.net/pcsx2/index.php?m=fulllist
Reply
#6
Thank you.

Current workaround for this issue is to use build 2175 (github), and patch 2F56CBC9.pnach.

Using this doesn't hang upon entering the door in the vision "A date with Tat" anymore, thus resolving my issue.
Reply




Users browsing this thread: 1 Guest(s)