Some problems in-game (PCSX2 - 0.9.8)
I was trying PCSX2 some days ago, i first used PCSX 1.0.0. Didn´t work well at all, i first used my Megaman X7 disc... Well, everything was sinking into the ground and i could see the back face of textures. I later tried with 0.9.8 and everything was right, except the textures. Later i tried Jak3 and everything was a mess... I've recorded a video of this one. I get low framerate, black textures, etc... Sorry, the video is in Spanish:

The specs of my PC are:
Soyo Xtreme-i7:
● 15,6" LCD-HD LED Backlight
● Intel Graphics HM55 Chipset (Processor has Intel HD Graphics 4000)
● 8 GB DDR3 1333 (Actually, it has upgraded RAM: Comes with 4GB)
● Hard Drive Disk: 1TB Sata II
● Processor: INTEL CORE i7 3632QM @2.20 GHz (8 CPU's)
● CD-DVD Unit speed: 8X
● Dual-Boot Ubuntu 13.04 & Windows 7 Ultimate 64-Bits. (Using Windows 7 for PCSX2).

I don´t know what to do to get the games working normally... I find that PCSX2 is a good emulator but, i can´t run it properly...

Sponsored links

Get a cpu clocked around 3.5 ghz and you should be fine in software mode.
Dont forget to activate mtvu speedhack, this should help.

But to be honest, 2.2 ghz is too weak for pcsx2, and even worse for a demanding game like jak 3
Ad a side note, we dont tolerate piracy here, and support will end here for you from what i saw in your video.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)