Strange bug in Devil May Cry 3 SE
I don't even know what to say, I've spent the whole day trying to find the source of it and alas, no luck.
It's simple: after Mission 3 there is a red door to the club and there should be a cutscene when Dante approaches the door. But nothing happens.
I have NTSC version (playing from iso) and asked my friend who has PAL version to give me it for a test, but the result is the same.

I tried using very old builds, starting from 4787 (the one with the blur fix) and then 4600. Currently I use latest 5397 build.
I tried all sorts of settings, even played with zerogs..

At first I thought that it's something with the savestates and memory cards, so I clean installed every version and started the game from the start. But nothing changed, except for that in older builds the sound is less jerky (a regression maybe?) and stutters less (during tutorial messages it starts to stutter). Maybe it may help devs here to track it.
Also I tried EU and USA bios, and again nothing changed.
And at last I tried "Mission 18 fix" settings with the same result.
I even had some weird thoughts about savestates breaking the scene, so I just used ingame saves, but it still didn't help.

So what is it? A bug? Maybe something more?
Except this stupid "bug" the game runs really good and I can even play it in 1080p in fullscreen, it's a shame that pc port is a total crap..

Thanks for any help. I don't think this is a bug, so I'm posting it in General Discussion.

P.S I also noticed that settings menu in pal and ntsc version is different (lock setting is right in the first menu in pal), also in pal on the loading screen there is "Devil May Cry 3" instead of "Loading". And you can choose Vergil right from the start. In ntsc I suppose you have to complete the game first. Pal version also gives you a choice between pal\ntsc and has built-in 60hz test.

Oops, I forgot to mention my config.
Core i5 2500k, 4Gb DDR3, GTX470, WinXP

Sponsored links

Are you 100% sure that scene is supposed to show with your NTSC version? Tried setting GSdx to software mode? Also make sure you're not using any patches or game fixes
[Image: newsig.jpg]
Of course I tried software, and even zerogs.
The scene should be there, it's just there, on pc or ps2.. I even watched youtube walkthroughs to make sure I'm not missing anything. The only thing is that I never launched dmc3 on pcsx2, before that I played that crappy pc port with my cousin's gamepad and the original ps2 version, but that was looong ago and I can't play it on ps2 anymore now (I simply don't have it anymore).

I haven't touched neither gamefixes menu nor hacks, but I tried messing with them randomly with no effect except some graphic glitches.
It seems I'm doing something really wrong, it should be simple and small, yet I'm missing it.

I think the best answer to my question would be to ask someone else check ntsc or pal version and see if that scene works. That should shed some light on the issue.
I doubt that I have some "special" version, its serial number is the same: SLUS-21361 for ntsc and SLES-54186 for pal.

Ok, random youtube search..
That's the start of the mission
and here is that scene
And that guy even triggered the scene before finishing the fight
And it appears the background of the main menu in pal version is purple instead of white. Strange. And after waiting and watching that movie which plays if you just do nothing - it becomes black.
Care to post your memory card with a save close to that point? Don't forget to rar it
[Image: newsig.jpg]
Ok, here is the memcard, sorry for the wait. I checked and it works with pal and ntsc.
And again I forgot to mention: I have set attack on X and jump on triangle, it's more convenient for the mouse, since x is used for menu selection. Just in case if you are used to default controls.

Attached Files
.rar   dmc3.rar (Size: 96,15 KB / Downloads: 203)
Well if you meant the cutscene that zooms in on the shotgun at the wall and shows the blue wall coming up, got it normally here Tongue
[Image: newsig.jpg]
Strange. Don't tell me I got two "broken" versions, it should be something else there if it's not connected with saves.
As I mentioned before, I made a clean install and checked with default settings with the same result.
Today I checked SSE2 and 3 dlls, nothing changed, I doubt it's something with the rendering part, more likely it's a complex issue that consists of other small things specific only for my system. I greatly suspect my WinXP. Well I have a netbook with Win7, I'll try to check there if it can launch the game lol.

It seems my netbook is too ancient to handle the game, it terminates with C++ error and error X4532: texlod not supported on this target.
Well it has Atom N455 1.66Ghz, 1Gb RAM and GMA 3150, it can barely run even the least demanding games, though 2d games run perfectly of course.
make sure skip mpeg is disabled
After googling that term it appears it was in the emulator a long time ago, and I can't find any option with mpeg skipping anywhere.
I think it's disabled by default. And besides, there is FMV before that mission and it plays fine. Also there where FMV before the game and in the main menu.
It should be something else. Tomorrow I'm going to visit my friend and check it on his pc to narrow the probability that it's a game issue and somehow both of my versions are "broken". If the cutscene works, then.. I think the only thing that is left is my windows. But there shouldn't be any problems with running pcsx2 on winxp, right? Other ps2 games I play work perfectly, it's the first time I've encountered such abnormality that I can't fix by myself, so I came here to ask for help.

Arrgh, as usual I'm too fast with the answer. No, the skip mpeg hack is disabled, like all game fixes.
It's not an FMV it's an ingame cutscene. No idea why it doesn't work for you, I'd suggest trying 1.0.0 with default settings and Gsdx simply set to DX10 renderer...are you using the internal iso reader to run the game?
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)