Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Time Crisis 2 & 3 Slowdown
Hello. Well every game I've fired at my setup has run at 60fps so far with both hardware and software modes.
I'm on the latest svn, my processor is an i5 2400 @3.4 ghz, 4 gigs of ram an ati 1 gb card and win 7 x64. Now enter Time Crisis II and III Angry.

Time crisis 2 starts right at the beginning of the first stage when you proceed out of the balcony and your overlook the square, fps drops to about 45 and the Emotion Engine spikes to like 95-100%.

Time crisis III starts right on the first stage as well when your on the beach shooting enemies while waves splash at your legs. Same thing, ee maxes out and sound stutters and fps drop.

I tried enabling the mtvu hack, did nothing. Tried hardware mode and software mode and both still happen and enabled all speeds hacks, no dice. Is there anything else I could try or is it that the emulation is poor for these games? I know they have been problematic untill recently but I can't see why my rig has ran every other game fine except these 2?

Sponsored links

Tried skipdraw 1 or 2? Here's how to enable it:
[Image: newsig.jpg]
(03-28-2012, 12:20 PM)Bositman Wrote: Tried skipdraw 1 or 2? Here's how to enable it:

Hey thanks for the reply. No didn't make a difference. I think its pcsx2. I ran some tests, my rig with frame limiter off runs the game at like 200% - 300%. When I get to these parts, fps drops to 40. In task manager all my ores are nowhere near being maxed out in these problem areas.

I think these games are getting to a point where they call for functions that pcsx2 is currently weak in emulating but I have no idea.

Any other things to try?

Users browsing this thread: 1 Guest(s)