Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Triangle button doesn't work after the iso has started
#1
I am using a ps4 controller. It itself works fine, I have binded all the buttons, so pcsx2 recognizes the input, but when I am in game the triangle button does not work.
The controller is not broken. I have tried to rebind it with no luck. Even binding the triangle button to the space bar on my keyboard didn't work.
Has anyone any idea why this might be?
Reply

Sponsored links

#2
(06-25-2020, 02:07 PM)Cskar Wrote: I am using a ps4 controller. It itself works fine, I have binded all the buttons, so pcsx2 recognizes the input, but when I am in game the triangle button does not work.
The controller is not broken. I have tried to rebind it with no luck. Even binding the triangle button to the space bar on my keyboard didn't work.
Has anyone any idea why this might be?

Same over here, It's been happening with all games since I started using version 1.6.0 for some reason.
Reply
#3
(06-25-2020, 02:07 PM)Cskar Wrote: I am using a ps4 controller. It itself works fine, I have binded all the buttons, so pcsx2 recognizes the input, but when I am in game the triangle button does not work.
The controller is not broken. I have tried to rebind it with no luck. Even binding the triangle button to the space bar on my keyboard didn't work.
Has anyone any idea why this might be?

Hello again, I've been messing around with the emulator and after many tests, I think I've found the solution, the buttons not working in some cases seems to be due to the XInput option in the controller plugin settings being checked by default in all versions of PCSX2 after 1.4.0 (at least), after I unchecked It (like you can see in the image I attached to this answer), the XInput in the Device Diagnostics list should dissapear and the controller should respond with all buttons again.


Attached Files Thumbnail(s)
   
Reply




Users browsing this thread: 1 Guest(s)