Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird Sly 2 performance issues
#1
Question 
OK, so I just played Sly 1 through all the way at 1080p, d3d11 hardware, and otherwise default settings with no slow downs. Here I am trying to play sly 2, using the safe room in the first world as a benchmark, and I can't get the FPS to go over 46. It won't go much below that, either. I've tried changing the resolution all the way from 256x256 to 8x native resolution and the framerate was actually about 4 frames better at 8x native?? Is this normal? I've never seen a game care so little about what resolution I set it to. I tried setting sly 1 to 256x256 out of curiosity and my framerate uncapped went from 75 to 120.

I've tried messing with speedhacks too and the only way I can get it at 60 is cranking them all until it's unplayable. Sly 3 runs only slightly better. I would just write it off as the games being intensive, but there are people on the pcsx2 wiki that claim sly 2 ran fine with specs nowhere near as good as mine. I feel like there's some specific setting or fix I'm missing, or something I messed up. As far as I'm aware I haven't forgotten about any settings that I changed.

Specs:
NVIDIA GeForce GTX 1050 Ti 4gb
Intel i7-3770 @ 3.4ghz quad core
8gb ddr3 ram
PCSX2 1.6.0
Reply

Sponsored links

#2
sly series tend to make weird things with gpu.
AFAIK, there has been some improvements about this issue on latest dev builds.

Care to try one ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
i downloaded the latest dev build, and it was running a lot better but it was still dipping a lot, especially when there were multiple enemies on-screen. i also tried a bunch more non-recommended settings to speed the game up, but it was still dipping horribly pretty often. EE is hovering at 95-100% at all times, GS is anywhere from 60 to 90. were these people just lying/confused on the wiki or is there something i'm not understanding? everything besides pcsx2 runs perfectly fine so i don't think anything is wrong with my computer.

i tried version 1.0.0 as that's what some of the people on the wiki were using, and it did run better than 1.6.0 but not quite as well as the latest dev build.
Reply
#4
Can you post a screenshot of gsdx settings that you are using?
Reply
#5
this is what i ultimately tried which helped a little. before i changed all of these i was using full default settings besides changing OpenGL hw to D3D11 hw because OpenGL hw runs like poop
   

edit: i already checked that "default hardware device" was properly using my gpu, nothing changes when i set it to the 1050 ti
Reply




Users browsing this thread: 4 Guest(s)