Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Will the XenoSaga saving crash every be fixed?
#1
I'm sorry if I sounded rude by the way the title comes off but I would really like to play this game without ha having to resort to save states. For me this glitch has been present for years and with pcsx2 getting better I was hoping if anyone would know as to why these actual save crystals crash?
Reply

Sponsored links

#2
at the moment there is only 1 save point during the evasion quest where you must not encounter any enemy...that is very serious crashes...there is very very percentage-of-coordinates where to step-on the save point that is not crashing...probrably near center of the save shield.
MAIN RIG:i5-7600(3.5ghz)GTX 1660Ti 6GB/192bit/gddr6/OC/WF,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,2pcs.Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
I never played the game on pcsx2(clear it twice on my PS2)but I wonder if this kind of code will solve the problem.
//Save Anywhere(Hold Select+Circle)
patch=1,EE,D0490D92,extended,0000FFFE
patch=1,EE,202442B8,extended,0240F02D
patch=1,EE,D0490D92,extended,0000FFFF
patch=1,EE,202442B8,extended,10620038

I don't remember...does the save crystal gives you access to anything else or it was just for saving
Reply
#4
The save anywhere code will work, however if you try it in the same area as the save point you still get the bug.

For instance, if you are on the Elsa on the same area as the save point, even if you are not in sight of the save point it will bug. You have to enter the bridge of the Elsa in order to save safely.

The way I did it was to save state before attempting to save in case I got the bug; if it bugged load state then move to another area and try again.

It should be noted that most save points work fine. You can pretty much figure out after a little while which ones are bugged.
Reply
#5
I posted this somewhere(github or here)but I notest something weird before on a save point that triggers the bug.
While the crystal is spinning,if you try to access the save function while the Crystal is facing in certain direction(either you see the face or the side,I don't remember),the problem will not get triggered.
I tried this 10 times and the problem never appear

But yes,save state before attempting is the way with this game
Reply
#6
As of now, no, the Xenosaga problem isn't solved and there doesn't seem to be a solution in sight.

A little hearsay from the rumor mill. I think it was in Discord someone mentioned an ancient thread about this problem where essentially the problem is a "If it's fixed for Xenosaga, everything else is *****, or, we can leave Xenosaga mostly working and everything else totally working" situation. That said, I have no further context so if someone from the "old guard" could give a "yeah that's about right" or "wtf did you hear this from", that'd be a good start.

From my own (minimal) investigation, all I can tell is that it does something and becomes VERY unhappy with itself, and just calls the exit syscall, which is why you back out to the PS2 browser. As of now, I actually don't think memcards are at fault (words I should use very lightly), but who knows maybe someone else will be able to tell what's going on with this one.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#7
Okay thank you for all the replies I'll try to use the save anywhere cheat code and see how it plays. I have a tendency to save my games a lot especially if i play for a short period of time so that's why i was wondering.
Reply




Users browsing this thread: 1 Guest(s)