Xenosaga I+II slowdown and frameskip issues
Here's the gist of it. I have Ep I and II here. I punted Ep II into working more or less perfectly with the old 0.9.6 release and the readily-available GSdx svn 2693. There was some slowdown in FMVs which was handily corrected with use of VU skipping. So I grabbed Ep I and ripped it (can't play Ep II without an Ep I save, ya know? Sacrilege!) and wasn't quite so fortunate. VU skipping results in frames getting stuck on screen while the audio continues in the background (i.e. the skip turns into a full-fledged flight). I also tried toying with things in r1888, but that version lacks VU skip, and for reasons I will now explain, frameskipping doesn't cut it.

Frameskipping doesn't work right at all in either game. If certain hacks are enabled (namely the idle fast forward from r1888), it just doesn't do anything. The game goes on as though it were just on frame limit mode. However, when it does do something, it certainly does no good. Instead of skipping frames, it just causes the game to go into seizures whenever something moves. It actually moves more slowly this way than without frameskipping. Both Ep I and II suffer from this problem.

I did some searching here and around the web and found the wikia (which may not be associated with the thing) suggesting that Ep I should work fine with PCSX2 r1888 and GSdx 1846, which makes me wonder if there may yet be a solution. I've gone over every hack I could find, tested different clamp settings, but I just haven't found that magical combination. Aside from compiling new versions and hoping for the best, I just don't have anything to go on. I need suggestions from others who may have seen these problems before. If I could just fix the frameskip issue either way, it would be fine.

For reference, PC specs:

AMD Phenom II 720 @ 3.5, 4th core unlocked
Radeon 4830 @ 650/950
4 gigs of old OCZ DDR2 @ some timings I don't care to look up

Games are NTSC

Important settings:
DX10 hardware mode
native res
no 8-bit textures
SPU2-X 2693, default settings

Every kind of speed hack from 0.9.6 and 1888 has been thoroughly tested, mostly with normal clamp and denormals are zero.

Also, if someone has GSdx 1846 sitting around, it couldn't hurt to test that as well.


Sponsored links

Frameskip was never working properly, due to known bugs in the code. We hope there will be a better version on the next release. About speed hacks, you wrongly assume that because they worked well on Xenosaga II they will work just as well on Episode I.
In fact Ep I is one of the most demanding games in terms of CPU speed and complexity, while as you found out yourself most hacks don't help.
Although you didn't mention what is your actual problem in Ep I, I assume it's low speed. In that regard, your best bet would be using beta 1888 along with the latest plugin pack from our site (which from what I see you are probably already using). Other than that, not much you can do I'm afraid
[Image: newsig.jpg]
I'm currently playing the same game without any speedhack at all and didn't notice any slowdown.

I'm using pcsx2 r1888 with gsdx 2693 sse41 in dx10 hardware mode native resolution with blendtff on and x16 experimental aa.
Framelimiting in limit mode. I'm not using microvu.

This on an i7 @4Ghz not that far from your Ph2.
if you have speed pbs, also put clamping to 'none'. It *WILL* mess up a few places, but that would be obvious and you can put it back then.

IT gives quite the boost.

I know i could play Xenosaga I on a 2.66ghz comp without too much slowdowns.
I see. The slowdown is actually relatively minor; it usually runs at 100% and only rarely dips below 90% (and only on the bridge thus far does it fall so low as 75%). Changing the clamping settings does help, but turning all the speed hacks on (sans EE and VU cycle hacks which more break than fix) with no clamping, flush to zero, and denormals are zero, it still falls down to 82% on the bridge and in the hangar. EE and VU cycle hacks cause framerates to increase but the game itself goes into slow-mo. It's really just frustrating that VU skip completely rectifies Ep II slowdown while it doesn't work properly with Ep I. Maybe I'll compile a more recent pcsx2 revision to give it a go.

Curiously, CPU never touches max load on any core during the slowdown, CPU load only says around 60% during these times on the PCSX2 readout and 45% on my other performance monitor, and pumping the AA to 16x doesn't add any slowdown at all. I suspect the problem is related to CPU load, though: some after-the-fact load balancing masking an overworked core (or a Biostar motherboard completely fudging load numbers Wink ). Ah well; maybe when they add quad core support...
Gamemako: those speed downs don't seem that bad lol.

Anyway, be wary of CPU load check programs, i know a few completely slowed my PCSX2. Also, there are some alread-compiled version on the web you can find easily (like 2888).
I tried the latest SVN, and it runs slower than the official beta (2-4 FPS less) in the ep1.
I use IOP x2 and INTC speedhacks, VU stealing doesn't gives me more real FPS, and the sound goes off sync, EE CR make it slower, and VU don't give me more FPS, cuz I don't use microVU.
Anyway, 90% in some rare cases, it's pretty good. I play it at 95%-100% normally and 70% in some rare cases. >_>
Athlon x2 240 2.8 GHz / HD5670 512MB / 2 GB RAM DDR2-800 / Windows 7 x64

"Pardoning the bad is injuring the good."

Users browsing this thread: 1 Guest(s)