Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xenosaga running very slowly on PCSX v1.4.0
#1
Hey guys, I'm trying to run Xenosaga episode I (and eventually episodes II and III) but its way too slow to even play. The same goes for cut-scenes, particularly the introduction simulation at the very beginning of the game.

My specs are below:
Intel i7-7700k four-core overclocked 4.5GHz (Kaby Lake)
GTX 1060 6GB GDDR5 
16GB DDR4 2400 SDRAM
ASRock Z270 Gaming K6 motherboard 
Corsair H105 liquid CPU cooler (in case this might be important.....)


My settings are posted below:
Emulation settings -- Speedhacks     
Plugins     
SPU-2     
GS    
HW Hacks is only "half-pixel offset"


I get around 75-90% speed with max limiter during some cut-scenes BUT then it plummets to 35-45% in game and during graphically intense scenes (I've attached examples below)

   
   


Is there anyway to fix this problem? Any help would be appreciated.
Reply

Sponsored links

#2
decrease internal res and set it to 4x
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(08-23-2017, 06:59 AM)jesalvein Wrote: decrease internal res and set it to 4x

Doesn't do anything.......still hitting below 50% speed during gameplay
Reply
#4
do you get the same results when using native ?
What about open GL renderer ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(08-23-2017, 03:16 PM)jesalvein Wrote: do you get the same results when using native ?
What about open GL renderer ?

Yep, I'm getting the same results when i decreased internal resolution, set int res to "native" and even when I changed to using OpenGL (as shown below)
P.S. I have windows 10 in case that affects anything

   
Reply
#6
make sure speed step is disabled, make sure power scheme is max performance for both the GPU and CPU so there is no downclocking happenin

current git build and stable 1.40 both run full speed for me 3x and 4x on 660gtx with below specs in Opengl
Reply
#7
(08-23-2017, 06:39 PM)tsunami2311 Wrote: make sure speed step is disabled, make sure power scheme is max performance for both the GPU and CPU so there is no downclocking happenin

current git build and stable 1.40 both run full speed for me 3x and 4x on 660gtx with below specs in Opengl

Excellent!!! Bumped up my card's performance level to "adaptive" and limited the PCSX2 speed (was hitting 800%+ speed!!!!!!!). Now I'm constantly hitting 100% speed.


Thank you!
Reply
#8
Nvidia's optimal power mode really does not like picking up various emulator loads as full graphical loads and clocking up to full speed/boost speed and will often sit at idle clocks for some inane reason.
Reply
#9
Optimal mode really sounds so low, rather ironic really. Would this also hinder my capability to play PC games or is it just on emulation? I may have to try it out......
Reply
#10
(08-24-2017, 03:44 PM)somethingoranother Wrote: Optimal mode really sounds so low, rather ironic really. Would this also hinder my capability to play PC games or is it just on emulation? I may have to try it out......

It should clock right back up to proper speeds when it detects a game and should dynamically adjust the clocks durring the game to use less power but keep up performance (on some cards and in the right games it works), but adaptive can do the same.  Optimal power also downclocks on the desktop and for some reason this is the mode most emulators end up in (depending on the card).
Reply




Users browsing this thread: 1 Guest(s)