Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Overclocking CPU - Audio Too Fast
#1
Hello everyone,

I have an issue with the sound. When I overclock my i7 860 from 2.8ghz to 3.2ghz, the sound ingame is jumpy. It will be playing smoothly, then speed up majorly for a second, and so forth. The music gets speedy at times because of this, or dialogue between characters goes by really fast. It also is a tad bit faster in general.

I have my FPS limit set to default (59.94) and the game is always running at max. Without overclocking, the game still runs at maximum FPS, but then the audio is normal. I could just leave it normal and not overclock, but it's an outstanding issue that I would like to fix (sometimes the game does drop below 60 FPS and this would ensure it stays at max).

Is this bound to happen? Is there a way to stop the fast sound, and have it stay normal? Note that ONLY the sound is going faster than normal... the game speed is how it should be.

OS: Win7 64bit
CPU: i7 860 @ 3.2ghz
GPU: Radeon HD 4890
PCSX2 0.9.7.2809
GSdx 2763
SPU2-X r2693 1.40
Speedhacks and Game Fixes all off

[Image: clipboard01xl.png]
Reply

Sponsored links

#2
Uh... so the FPS get higher than 60 when the audio is too fast? or is it always 60FPS and the sound is still too fast?

If the case is the first make sure you have frame limiter set to "limit".
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(04-07-2010, 04:23 AM)Shadow Lady Wrote: Uh... so the FPS get higher than 60 when the audio is too fast? or is it always 60FPS and the sound is still too fast?

If the case is the first make sure you have frame limiter set to "limit".

I stated that my limiter is on and that it is always maximum FPS (59.94).
Reply
#4
Make sure that when you overclock the buses of the system stay on their proper speeds. I had a problem once when I overclocked my system, my raid setup using hardware card (Adaptec) would crash. I figured it out after 2 years of use (not overclocked, because whenever I did it would simply crash) : it was the PCI bus speed! The card simply did not like the increased speed which was automatic when overclocking, but settable back to normal via bios option. Maybe it's some sound card working strangely with increased bus speed losing track of timing. This is extremely unlikely today, most likely there is some other problem, but investigate this as well Wink
i7 @ 3.2Ghz /w Noctua
6GB Dominator 1600Mhz
5770 Vapor-X
1.5 TB Raid 5 /w 3ware 9650SE

Reply
#5
(04-07-2010, 05:12 AM)mantasuk Wrote: Make sure that when you overclock the buses of the system stay on their proper speeds. I had a problem once when I overclocked my system, my raid setup using hardware card (Adaptec) would crash. I figured it out after 2 years of use (not overclocked, because whenever I did it would simply crash) : it was the PCI bus speed! The card simply did not like the increased speed which was automatic when overclocking, but settable back to normal via bios option. Maybe it's some sound card working strangely with increased bus speed losing track of timing. This is extremely unlikely today, most likely there is some other problem, but investigate this as well Wink

I'm using onboard sound.
Reply
#6
Well, the onboard sound still has to be somehow connected to the north/south bridge... So the point is still valid (in my view) Smile
i7 @ 3.2Ghz /w Noctua
6GB Dominator 1600Mhz
5770 Vapor-X
1.5 TB Raid 5 /w 3ware 9650SE

Reply
#7
(04-07-2010, 05:22 AM)mantasuk Wrote: Well, the onboard sound still has to be somehow connected to the north/south bridge... So the point is still valid (in my view) Smile

Well in that case, everything, all sound should be speeding up... but it is only PCSX2 (every other game, application operates with normal sound). I've also never experienced a system or hardware crash.
Reply
#8
Have you tried playing around with the time streching and latencies in the audio cofig area of PCSX2. Maybe you could scrap the overclock and swap the frame limiter for auto frame skip as it would only skip every so often anyway.
E5500 @ 3.6Ghz PNY DDR2 @850Mhz 5-5-5-14 ** GTS250 ECO @ 683/1674/1018
Reply
#9
PCSX2 0.9.7.2809
GSdx 2763
SPU2-X r2474 1.30

I tried disabling time stretching and it didn't help. I tired switching the sound module as well to no avail. The thing is, I see no reason why my overclock would cause this to happen (as other people overclock and I could find no one else with this issue). I would like to be able to overclock and use PCSX2 to its full potential.

EDIT: Just tested with Final Fantasy XII and the problem occurs the same here too.

EDIT2: Updated plugin to latest (1.40) and nothing has changed. Tried with P.E.Op.S SPU2 and the issue is still there, but the sound is just constantly slightly speeded up (it's not jumpy).

EDIT3: Picture

[Image: clipboard01xl.png]
Reply
#10
So you're using an unsupported build... little detail to be left out...

Anyway press the F4 and Tab keys to see if they help at all, if not use the latest public beta or stable which should work just fine. The new GUI builds are not supported and can be glitchy so good luck with that.
http://forums.pcsx2.net/Thread-PCSX2-off...ta-plugins
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)